WordPress.org

Ready to get started?Download WordPress

Forums

Weird htaccess issue? (4 posts)

  1. anthonymcg
    Member
    Posted 8 years ago #

    Hi all,

    I upgraded to WP2 about two weeks ago now but have been having sporadic problems with a particular plugin related to htaccess (I think). I use the FAlbum plugin to display my flickr photosets and pics within my site (Linky) but since the upgrade some users have been reporting 404s when browsing the sections of the site controlled by FAlbum.

    Since WP2 handles the htaccess rules differently, I moved the FAlbum htaccess instructions above the WordPress ones as below:

    # BEGIN FAlbum
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^photos/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?([^/]*)?/?$ /wp-content/plugins/falbum/falbum-wp.php?$1=$2&$3=$4&$5=$6&$7=$8 [QSA,L]
    </IfModule>
    # END FAlbum
    RedirectMatch temp ^/blog$ http://www.anthonymcg.com
    RedirectMatch temp ^/blog/$ http://www.anthonymcg.com
    ErrorDocument 404 /index.php?error=404
    RedirectMatch temp ^/gallery.php$ http://www.anthonymcg.com/photos/
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    I've tried the FAlbum forums and haven't got much luck so I'd appreciate some help if there's anyone out there familiar with things like this. Thanks a million.

    Anthony

  2. anthonymcg
    Member
    Posted 8 years ago #

    Sorry to bump this but does anyone have any thoughts?

  3. anthonymcg
    Member
    Posted 8 years ago #

    Right, I think I'm starting to understand what's going on. Any of the albums or pages below the main FAlbum page are given 404 response headers. For example this page (http://www.anthonymcg.com/photos/show/recent/) has the following headers:

    Date: Fri, 13 Jan 2006 15:09:56 GMT
    Server: Apache Web Server
    Cache-Control: no-cache, must-revalidate, max-age=0
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Pragma: no-cache
    X-Pingback: http://www.anthonymcg.com/xmlrpc.php
    X-Powered-By: PHP/4.4.1
    Last-Modified: Fri, 13 Jan 2006 15:09:56 GMT
    Keep-Alive: timeout=5, max=150
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html

    404 Not Found

    I can't for the life of me, figure out why it's doing that though. I wasn't too sure what was happening before as Firefox displays the page as normal whereas if you use IE (with Friendly http error messages set to on) then you get the 404 page. Is this a problem with WordPress or FAlbum?

  4. dnvang
    Member
    Posted 8 years ago #

    This seems to be a problem with WordPress' handling of rewrites and incorrectly sending out 404 headers for pages that exist using other rewrite rules.

    I devised a solution detailed on my blog:

    http://cyberbrain.prime-artifice.com/2006/03/15/quick-notes-on-modifying-wordpress-20x-permalinks-to-work-with-falbums-friendly-urls/

Topic Closed

This topic has been closed to new replies.

About this Topic