WordPress.org

Ready to get started?Download WordPress

Forums

Weird [function.curl-setopt] after upgrading to 2.9 (19 posts)

  1. zakshow
    Member
    Posted 4 years ago #

    I upgraded to version 2.9 and I had a problem, when trying to post a post, update or to do anything via admin panel I get a bank page with this error code:

    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1302
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1303
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1302
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1303
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1302
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1303
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1302
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /wp-includes/http.php on line 1303
    
    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/http.php:1302) in /wp-includes/pluggable.php on line 868

    What is the problem? Do I need to modify something or it is from the new version?

  2. jonradio
    Member
    Posted 4 years ago #

    Based on the lack of response to this post on the cforms forum, I'd say we are all going to have to wait for the plug-in developer to address the issue:
    http://www.deliciousdays.com/cforms-forum/troubleshooting/help-wordpress-29-and-curl_setopt-error/

  3. zakshow
    Member
    Posted 4 years ago #

    The problem is from the XML Google sitemap, that's why when you want to publish or update a post you get that error message, because after updating or publishing, the plugin is called to rebuild the sitemap automatically.. I disabled the plugin and things got back to normal.. or just uncheck the options that make the sitemap get updated automatically after the blog content is edited.. Try it and let me know..

  4. zakshow
    Member
    Posted 4 years ago #

    When desactivating the google xml sitemap plugins, my new posts are not indexed by SE, my latest blogpost is not indexed correctly the permalink is screwed!! What is the solution? Any help?

  5. VulturesAwait
    Member
    Posted 4 years ago #

    I do not have the XML Google sitemap plugin set up in my blog yet, so this might not be the cause. The error message shows up in the WordPress backend site as well as on the FRONT of my blog in right-hand the widget panel.
    http://vulturesawait.com

    Right above where the Tweet feed box is.. the code error shows up.

    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/vultures/public_html/wp-includes/http.php on line 1302

    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/vultures/public_html/wp-includes/http.php on line 1303

  6. Denis de Bernardy
    Member
    Posted 4 years ago #

  7. Denis de Bernardy
    Member
    Posted 4 years ago #

    It also helps to not use a host that enables safe_mode or open_basedir, though.

  8. agreda
    Member
    Posted 4 years ago #

    I got this curl error appearing atop the plugins page after upgrading and the semiologic patch cleared them right up. Cheers to that!

  9. grutkowski
    Member
    Posted 4 years ago #

    This should be fixed in 2.9.1 ...

    See http://core.trac.wordpress.org/ticket/11499 and http://bugs.php.net/bug.php?id=49531

    Many people are seeing this come and go due to a timing issue -- lots of plugins are being blamed, but it's core code that needs to be fixed.

  10. ucero
    Member
    Posted 4 years ago #

    I have the same problem after upgrading to WP 2.9. I dropped the cforms plugin, but my error occurs and Google XML Sitemap plugin. (when rebuild the structure manually - Enable manual sitemap building via GET Request)
    The site works fine, but the error appears in several places and is stressful. (appears to: WordPress Development Blog, Plugins, outside links...)
    I guess they are guilty and some server settings, because I have a wordpress site on another server without this error. Problem beyond me, I hope to find a solution.

    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in .../wp-includes/http.php on line 1302
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in .../wp-includes/http.php on line 1303
  11. Denis de Bernardy
    Member
    Posted 4 years ago #

    ureco: see the above comment. know 2.9 bug, fixed in the coming 2.9.1

  12. ucero
    Member
    Posted 4 years ago #

    Yes ... thanks for the reply.

  13. S.K
    Member
    Posted 4 years ago #

    Thanks, Denis-de-Bernardy. Your patch worked like a charm!

    And about the "open base-dir", should I take it up with the host? What exactly does it hamper my blog's functioning, please?

    Regards

    S.K

  14. S.K
    Member
    Posted 4 years ago #

    == Duplicate ==

  15. ucero
    Member
    Posted 4 years ago #

    After upgrading to WordPress 2.9.1 the problems have disappeared. Thanks to those who worked for WordPress to function without these errors.

  16. ronhosner
    Member
    Posted 4 years ago #

    Thanks for useful info. Will upgrade soon.

  17. macsters
    Member
    Posted 4 years ago #

    I am also having problems with the Google XML Sitemap after upgrading to 2.9. I don't get the above errors but my sitemap has not updated since I did the upgrade. I unchecked automatic update and used the manual rebuild but that did not update the sitemap either. It also shows an error trying to send it to Ask.com. I have upgraded to 2.9.1 but it still does not work. Can anyone give me any insight on what I need to do to get this to work. Thank you.

  18. moongoose
    Member
    Posted 4 years ago #

    I was having issue with Google XML Sitemap not updating for the first time a week ago, but we were still using 2.8.4. We had never had problems prior to last week with Google XML Sitemap. I'm wondering if it has to do with the version of Google XML Sitemap, as I had just upgraded that but not WP yet.

  19. rudy3107
    Member
    Posted 4 years ago #

    I upgraded my site http://mynation.net to 2.9.1.1 and got this http error

    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/noname/public_html/wp-includes/http.php on line 1302

    I think WP guys did not fixed Problem, or may be this Problem is not with widget / RSS / XML may be its SERVER related.

    and i also have another site http://supari.org hosted on other server whihc is not giving any ERROR.

    to fix http://mynation.net error, i just downloaded

    http://www.semiologic.com/2009/12/21/wp-2-9-three-bugs-and-how-to-fix-them/ 3 files from here and updated and ERROR Gone.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.