WordPress.org

Ready to get started?Download WordPress

Forums

weird formatting when switch between tinymce and html editor (7 posts)

  1. abbyj
    Member
    Posted 2 years ago #

    Beginner to wordpress here -- yes I know you're not supposed to switch between the 2 editors but I did. Now I'm back to the visual editor and fixing paragraphs.
    My formatting is crazy and I found this at top of html - which I did not put there.

    div id="yass_top_edge_dummy" style="width: 1px; height: 1px; padding: 0px; margin: -9px 0px 0px; border-width: 0px; display: block;"

    div id="yass_top_edge" style="background-image: url('chrome://yass/content/edgebgtop.png'); background-attachment: scroll; background-position: center bottom; padding: 0px; margin: 0px 0px 8px -8px; border-width: 0px; height: 0px; display: block; width: 828.45px;"

    what is this? Should I delete it in html, save and then try to edit in visual editor?

    thanks in advance

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Try using any one editor of your choice for posting the same content. If that comes out OK, delete the post that was formatted badly.

  3. abbyj
    Member
    Posted 2 years ago #

    yes, I've done that but just curious if the html serves a purpose. thanks!

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Yes, many people use mainly the HTML editor just because if correctly used, it gives better formatting.

  5. Ahjetztja
    Member
    Posted 1 year ago #

    Hi abbyj,

    I faced the same phenomena as you and it drove me crazy. But now I found the problem. I bet you are using firefox with an add-on called yet another smooth scrolling. This add-on is the culprit. More precisely it is the feature called elastic edge. This feature adds some code (edge with shadow) to the actual page whenever the scrolling reaches the top or bottom border. Normally this should be okay as the code disappears, when you leave the site. But if you are using an editor like TinyMCE (or any other javascript based editor) this code is injected into the post.

    The solution: Just go to the setting of yass add-on and turn off elastic edges and your done.

    best regards,
    Oliver

  6. abbyj
    Member
    Posted 1 year ago #

    hi - that worked for a while and now it's not. I do have "bouncy edge" turned off. Any ideas? thanks

  7. votruh
    Member
    Posted 1 year ago #

    Thank you. Had this problem on Joomla 2.5 editor JCE. For your advice turned off Firefox extension Yet Another Smooth Scrolling.
    Thank you again.

    P.S. I am from Russia. I apologize for my bad English.

Topic Closed

This topic has been closed to new replies.

About this Topic