WordPress.org

Ready to get started?Download WordPress

Forums

Weird excert problem [WP adds portion of excerpt after last post excerpt on IE] (8 posts)

  1. RichardSapien
    Member
    Posted 4 years ago #

    Hey everyone, thanks for taking time to read this. I'm relatively new to WP (a month in or so), yet this is the first problem I have yet to crack for myself.

    As you can see at: http://www.professionaldevelopment101.com/eventscalendar, the last post excerpt adds a portion of the excerpt below the excerpt I have. This only happens in IE 7. This may be different/worse in older versions. The page renders fine in Firefox.

    The weirdest thing is that this text excerpt renders without appearing in the source code, and it is hard to select (if at all) on the page. Weird properties.

    I had Advanced Excerpt installed, but I deactivated it to debug and I'm still having problems. Any ideas?

    Thanks.

  2. RichardSapien
    Member
    Posted 4 years ago #

    I haven't changed anything, but right now I loaded up the screen and the rendered excerpt was different- there was also added excerpt test to one of the other postings. I refreshed the page and now it looks like I did when I first made this post.

    There is definitely some type of rendering problem with something. I hope someone has a good idea of where to look. Thanks.

  3. s_ha_dum
    Member
    Posted 4 years ago #

    The weirdest thing is that this text excerpt renders without appearing in the source code, and it is hard to select (if at all) on the page. Weird properties.

    If it appears on the page it has to appear in the source unless, maybe, something like Javascript is duplicating the content. Not all source code viewers will pick up dynamically generated code. So Javascript is where I'd start to look. Maybe your IE has old libraries. If that's the case though fixing this could be tricky. Basically, you'd have to get the JS to fail safe with old libraries.

  4. RichardSapien
    Member
    Posted 4 years ago #

    There is only one JavaScript which I temporarily removed and still experienced the same problem. Take a look- the extra excerpt clippings are not in the code.

    Anyone else have an idea?

  5. RichardSapien
    Member
    Posted 4 years ago #

    The problem seems to be fixed in IE8. Maybe I'll just suggest that everyone updates their IE.

  6. RichardSapien
    Member
    Posted 4 years ago #

    Nevermind- still having the problem.

    Here is a screenshot of what I'm talking about: http://img13.imageshack.us/img13/589/wtfslg.jpg.

    Anyone?

  7. s_ha_dum
    Member
    Posted 4 years ago #

    I don't see that effect but your code does seem to be generating some bad markup. These are closing paragraph errors too. That kind of error can cause formatting problems. I'd clean that up before proceeding.

  8. RichardSapien
    Member
    Posted 4 years ago #

    It's all cleaned up, yet still no luck. Thank you for taking a look though.

    I checked out the site on other computers/IEs and I'm seeing the same thing. Weird.

Topic Closed

This topic has been closed to new replies.

About this Topic