WordPress.org

Ready to get started?Download WordPress

Forums

Weird code gets added... (2 posts)

  1. Arnan de Gans
    Member
    Posted 5 years ago #

    Hi there, i maintain the Events plugin (http://meandmymac.net/plugins/events/) And after a recent update there are some people complaining about the output of the plugin. Note that i made a stripped down version of the wp editor to allow easy formatting of HTML, basically people can use the HTML view of the WYSIWYG editor to help them writing html.

    All nice and neat. But now i get complaints about this line being added.
    <pre class="xhtml" style="font-family: monospace;">
    around my plugins output.

    I have no idea where it comes from other than that TinyMCE messes with the input the user gives. Can it be disabled? Why is it there in the first place and how to fix it? There is a fix proposed in the below thread. But that still leaves the <pre> tag in place i think. Which shouldn't be there in the first place.

    There are some threads on my forum about it, biggest here: http://forum.at.meandmymac.net/topic/events-page-extends-to-the-right

    The worst thing is that i cannot reproduce the error. I use Safari for a browser. The users reporting this use Firefox, some of them do anyway, some haven't said. One claims that it works fine in IE. So i'm at a loss what's up.
    http://forum.at.meandmymac.net/topic/wrap-text

    Any ideas? Thanks a bunch!

  2. Arnan de Gans
    Member
    Posted 5 years ago #

    bump, anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic