WordPress.org

Ready to get started?Download WordPress

Forums

weird bug (7 posts)

  1. piginzen
    Member
    Posted 9 years ago #

    I get this on my index.php page every few times:
    Warning: ob_start(): output handler 'ob_gzhandler' cannot be used after 'URL-Rewriter' in /home2/olympus/public_html/02/wp-includes/functions.php on line 452
    Has this happened to anyone else in the past?
    Thanks,
    mat

  2. piginzen
    Member
    Posted 9 years ago #

    i am still getting this after cleaning up some more of my index.php deleting old calls...
    it appears to happen more often than not when loading the page for the first time just after the browser has been loaded...
    it also doesnt seem to matter what browser i use (Firefox, IE, Safari, etc) - As well as OS... Win XP or OSX....
    Does anyone have any ideas?
    PS. this Warning is at the very top of the index.php

  3. carthik
    Member
    Posted 9 years ago #

    Try Disabling the "WordPress should compress articles (gzip) if browsers ask for them" option in Options->Reading. This happens because Apache already compresses the output due to your php.ini settings as used by your host.
    You can find out if the output is gzipped even after you turn the options off by using the service at http://www.websiteoptimization.com/services/analyze/

  4. piginzen
    Member
    Posted 9 years ago #

    I tried that and so far so good.
    Thanks so much.
    I looked at that URL you gave me, but it didnt tell me that information.
    Regardless, does GZIP do that much? What actually does it do for WP?
    Thanks again,
    mat

  5. Anonymous
    Unregistered
    Posted 9 years ago #

    how did you fix it Mat? Im having the same problem

  6. piginzen
    Member
    Posted 9 years ago #

    i just did this:
    Try Disabling the "WordPress should compress articles (gzip) if browsers ask for them" option in Options->Reading.
    havent received that error since...

  7. pcdinh
    Member
    Posted 9 years ago #

    Hi all, I have also had this error in my web site. I did as you recommended and it worked. I guess that my server has enable mod_gzip, so I dont need tp config WordPress to do so.
    Dinh
    http://www.phpvietnam.net

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.