WordPress.org

Ready to get started?Download WordPress

Forums

WP Fastest Cache
[resolved] Website Not working after deactivating wp fastest cache (7 posts)

  1. kamrankhalilcuremd
    Member
    Posted 7 months ago #

    Hello,

    My website stopped working after deactivating wp fastest cache. Only homepage is working, all other links are giving 404 error. I activated the plugin again and all links started working fine. Please tell me why this happening, I want to remove this plugin. Please also note that I used w3 total cache and wp super cache before installing this plugin but they were deactivated and removed when I installed this. Now my website goes down (except homepage) when i deactivate this plugin. Please reply me as soon as possible.

    http://wordpress.org/plugins/wp-fastest-cache/

  2. Emre Vona
    Member
    Plugin Author

    Posted 7 months ago #

    It is impossible :( Please tell me your web site url

  3. kamrankhalilcuremd
    Member
    Posted 7 months ago #

    Its http://www.tog.com.pk.
    Website is working fine, when plugin is "not enabled". But as soon as I deactivate the plugin from plugins page, all pages except home page and admin panel give 404 error.

  4. Emre Vona
    Member
    Plugin Author

    Posted 7 months ago #

    I think that the other rewrite rules on .htaccess cause the problem.

    First, you can remove the rewrite rules of wpfc and later you can try deactive.

  5. kamrankhalilcuremd
    Member
    Posted 7 months ago #

    When I remove following code from my .htaccess file, 404 error starts coming, it goes normal when i insert this code again.

    # BEGIN WpFastestCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{DOCUMENT_ROOT}/MyWebsiteMainAddressHere/$1/index.html -f
    RewriteRule ^(.*) "/MyWebsiteMainAddressHere/$1/index.html" [L]
    </IfModule>
    # END WpFastestCache

  6. kamrankhalilcuremd
    Member
    Posted 7 months ago #

    OK i think I fixed the issue. There is wordpress chunk in .htaccess file below this code. It doesn't have the following two lines:

    RewriteEngine On
    RewriteBase /

    Because they were already added by WPFastestCache chunk. I simply added these two lines to wordpress chunk in .htaccess file. I think your plugin should do this, I am using WordPress 3.8 and pretty permalinks are ON. Maybe this issue is version specific or due to permalinks being ON. Thanks for your help though.

  7. Emre Vona
    Member
    Plugin Author

    Posted 7 months ago #

    your welcome :)

Reply

You must log in to post.

About this Plugin

About this Topic