WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Website not displaying well on IE (4 posts)

  1. mpanty
    Member
    Posted 6 years ago #

    Hi. I've just recently installed WordPress on my site http://www.mcalcio.com.

    I was playing around with the .htaccess file in order to write a 301 redirect (to redirect all traffic from mcalcio .com to www. mcalcio. com), and afer that worked (I tested it, the site was displaying fine and the redirect was working) I uploaded a favicon.ico file to the the root folder, to have the icon display in the favorites whenever someone bookmarked the site.

    After uploading the favicon file, the website stopped displaying correctly in IE. It displays correctly with Firefox, but none of the links work: you cannot access comments, click on direct links to posts, nothing...

    Can anyone help? I tried removing the favicon.ico file, didn't change anything.

    I'm wondering if the problem lies in my .htaccess file, the index.php, or somewhere entirely different.

    For reference, this is the code I have in my .htaccess and index.php files:

    .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    Options +FollowSymLinks
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^mcalcio\.com$ [NC]
    RewriteRule ^(.*)$ http://www.mcalcio.com/$1 [R=301,L]

    index.php

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>
  2. Aleister
    Member
    Posted 6 years ago #

    The problem is that you are forcing it to use 'www.' but you are using the non-www links to point to your CSS, etc..

    Firefox and IE7 handle this fine, but IE6 complains :)

    Make sure any links in your theme's header.php file use the 'www', and also make sure in your WordPress options, you are using the 'www' form in both the 'wordpress address' and 'blog address' options.

  3. mpanty
    Member
    Posted 6 years ago #

    Dead on the money Aleister! :) I introduced the 'www' form in both 'wordpress address' and 'blog address' in the option menu, and now it's working fine. Many thanks for your help!

    It's strange though that after I added that 301 redirect code, it tested fine immediately after. Could it be that the site was still in by browser's cache? (then I guess I must have closed the browser or something, clearing the cache and then it stopped working). Am I guessing correctly or are completely off?

    By the way, my theme's header.php had no links pointing to my website (neither with www or without). Then again, I don't need to touch that file since everything seems to be working now.

  4. Aleister
    Member
    Posted 6 years ago #

    The cache is very likely.

    As far as you header file, that is fine. I had noticed the link to the CSS file did not use the www, but it sounds like it was using a function to generate the url, instead of it being hard-coded, so as soon as you changed the option, this was updated as well :)

Topic Closed

This topic has been closed to new replies.

About this Topic