WordPress.org

Ready to get started?Download WordPress

Forums

Website Hacked (6 posts)

  1. sowar_hussain@live.co.uk
    Member
    Posted 1 year ago #

    I think my website has been hacked.

    http://www.imagine-studios.co.uk

    If I have the .htaccess file the website re-directs to auto-im.com

    if i remove the file the website is fine however the pages are not loading in full

    I have opened the the .htaccess file and I cannot see anything up towards. See below what is within the file:

    # Do not remove this line, otherwise mod_rewrite rules will stop working
    RewriteBase /

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    i tried looking for a solution everywhere and followed so many things to try and locate the hack. Im completely at a loose end....plz plz someone help

  2. leejosepho
    Member
    Posted 1 year ago #

    # Do not remove this line, otherwise mod_rewrite rules will stop working
    RewriteBase /

    I do not know what your problem might be, but do you know why that line is there? To me, that looks a bit suspicious.

  3. sowar_hussain@live.co.uk
    Member
    Posted 1 year ago #

    I have gone through all the links above and cannot find anything suspicious.

    I have tried updating from an old version of wordpress to v 3.5.1 but I get stuck on the screen for ages:

    Update WordPress
    Downloading update from http://wordpress.org/wordpress-3.5.1-new-bundled.zip…

    I have also downloaded wordpress 3.5.1 and re-uploaded everything including my theme and I get 2 PHP errors.

    I am going around in circles and no body seems to know what the problem is :(

  4. Jon Jacobs
    Member
    Posted 1 year ago #

    did you figure it out? my theme has the same problem and I have yet to solve it. Your site seems to load up fine on my machine which leads me to assume that you solved the issue.. please share!!

  5. sowar_hussain@live.co.uk
    Member
    Posted 1 year ago #

    Hi Jon

    I think I figured it out. I downloaded a new version of the theme and uploaded all the files and it seems to be working fine now.

    However i did have a few issues with Word Press 3.5.1. Its not functioning properly and the dashboard is not responding as it should. When i tried creating pages or posts they would disappear. When i tried recreating them it kept saying I didnt have rights to publish when I am the administrator of my account.

    I had an old version of WordPress 3.5 so I installed that and uploaded my theme and its seems to be working ok however there are a few glitches with this versions aswell.

    My really old version of wordpress 2.5 (i think)always worked fine, never had any issues. I am still running on wordpress 3.5 as I am scared if I upgeade, my site will go down and I will have issues making any chnages.

    does anyone else have issues with wordpress 3.5.1?

Topic Closed

This topic has been closed to new replies.

About this Topic