WordPress.org

Ready to get started?Download WordPress

Forums

Website displays blank page (20 posts)

  1. brew13
    Member
    Posted 3 years ago #

    My WP website, http://www.crankitupcoogs.com, displays a blank page. The site has been up and running for over a year and I haven't made any changes in months so I suspected my shared server hosting company and opened a support ticket. They responded with the message below:

    We checked your domain and enabled debug for wordpress application. We found that some of plugins/themes within wordpress causes the problem, as the following error message appeared:
    Notice: Undefined index: action in /hsphere/local/home/sunrayftp/crankitupcoogs.com/wp-content/plugins/share-on-facebook/shareonfacebook.php on line 201 Notice: Use of undefined constant widget_share_on_facebook_register - assumed 'widget_share_on_facebook_register' in /hsphere/local/home/sunrayftp/crankitupcoogs.com/wp-content/plugins/share-on-facebook/shareonfacebook.php on line 266 Parse error: syntax error, unexpected '?' in /hsphere/local/home/sunrayftp/crankitupcoogs.com/wp-content/themes/cityguide/functions/admin-setup.php on line 299
    Please re-check your plugins and disable corrupted in order to resolve the issue. Let us know if you need any further assistance.

    I changed the name of the plugins folder to temporarily disable the plugins. This didn't help. I have also checked and another of my WP sites has the same problem. Now, I suspect malicious activity.

    Does anyone have any ideas? Thank you.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried switching to the Twenty Ten theme to rule out any theme-specific problems?

  3. brew13
    Member
    Posted 3 years ago #

    I can't log-in and get to dashboard. How can I switch using Filezilla?

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Switch to the Twenty Ten theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

  5. brew13
    Member
    Posted 3 years ago #

    I'm not following you. I have /wp-content/themes/ and 4 theme subfolders of which one is Twenty Ten. What do I need to do to switch? I appreciate your assistance.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Rename the folder belonging to the theme that you were previously using.

  7. brew13
    Member
    Posted 3 years ago #

    Follow up - I edited the theme's folder name to temporarily disable the current theme. I assume now that WP will default to Twenty Ten. If so, the website display is still blank.

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    Now try logging in.

  9. brew13
    Member
    Posted 3 years ago #

    I can log in. What is going on? Why would this happen to 2 websites?

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    You chose bad, poorly coded, themes?

  11. brew13
    Member
    Posted 3 years ago #

    I don't think so. The themes have been up and running for a long time. I don't want to advertise but the themes come from the firm with woo in the name.

  12. brew13
    Member
    Posted 3 years ago #

    The Twenty Ten theme doesn't display. I can only log-in.

  13. esmi
    Forum Moderator
    Posted 3 years ago #

    Then you have deeper problems within your sites. Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. I'd also suggest that you try reviewing:
    http://codex.wordpress.org/FAQ_My_site_was_hacked
    http://wordpress.org/support/topic/268083#post-1065779
    http://smackdown.blogsblogsblogs.com/2008/06/24/how-to-completely-clean-your-hacked-wordpress-installation/
    http://ottopress.com/2009/hacked-wordpress-backdoors/

  14. brew13
    Member
    Posted 3 years ago #

    Since this issue happened at generally the same time to more than one website does that point to hacking? I have the same password for all my websites. I'm going to start reading the links that you provided.

  15. brew13
    Member
    Posted 3 years ago #

    Found out that Twenty Ten will display. So that indicates the WordPress installation is good. Still no idea what is wrong though.

  16. esmi
    Forum Moderator
    Posted 3 years ago #

    Since this issue happened at generally the same time to more than one website does that point to hacking?

    To some extent but it could also point towards a server problem that resulted in files becoming corrupted etc. Changing your passwords so that you have different ones for each site would be a very good idea anyway.

  17. brew13
    Member
    Posted 3 years ago #

    Thank you. I'm going to read the links that you provided and re-install some theme files.

  18. brew13
    Member
    Posted 3 years ago #

    Hello, I believe that the problems are due to malicious hacker attack. This is a University of Houston booster website and I don't know why anyone would want to hack it. I am considering doing a new WordPress and theme installation. Before I do, I would like to understand the vulnerability. I have put two links to screenshot jpgs. Do you recognize this? I'm asking so (1)hopefully if someone has had this happen to them I can learn from their experience and (2) can anyone tell me if I need to do something with the database. Thanks.
    http://www.crankitupcoogs.com/images/screenshot1.jpg
    http://www.crankitupcoogs.com/images/screenshot2.jpg

  19. rukky
    Member
    Posted 3 years ago #

    a similar things is happening to me...
    i'm trying to set a site up... http://www.pediaboy.com , i just used the text widget to add some icons to the side and geuss what i saw?

    "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in pediaboy/public_html/wp-admin/includes/user.php on line 121"

    now, i cant even load my admin page, the only thing that comes out is this error message. please what should i do please?

  20. brew13
    Member
    Posted 3 years ago #

    I don't know other than to follow the steps that were recommended to me. I still haven't solved my problem. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags