WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
website dead by upgrade of si-contact-form (7 posts)

  1. crypted
    Member
    Posted 4 years ago #

    I upgraded to WordPress 3.0, followed by an upgrade of SI-CONTACT-FORM to 2.7. The system broke and the website can only be viewed by DELETING the SI-CONTACT-FORM directory...which sucks to have to do!!!

    I tried downgrading to 2.6.5 (which was the last one I was using), and it won't work that way either, now.

    Here's the problem:

    Warning: session_start() [function.session-start]: open(/var/www/clients/client1/web26/tmp/sess_ffa61689d606b9aa3ef614d4704eaa64, O_RDWR) failed: Permission denied (13) in /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php on line 1068
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php:1068) in /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php on line 1068
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php:1068) in /var/www/clients/client1/web26/web/wp-includes/pluggable.php on line 890
    
    Warning: Unknown: open(/var/www/clients/client1/web26/tmp/sess_ffa61689d606b9aa3ef614d4704eaa64, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    
    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/www/clients/client1/web26/tmp) in Unknown on line 0

    How can this be resolved?

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    PHP sessions are required to set a cookie, or the CAPTCHA will not work.

    This error is telling you the PHP sessions are broken on your server
    installation because it cannot find or read the session directory. Make
    a trouble ticket with your web host. Send them the error and a URL link
    to the page with error. They will fix it.

  3. crypted
    Member
    Posted 4 years ago #

    I'm my own webhost. I can tell you it's a FAST-CGI related issue. I put it on MOD_PHP and it worked fine... But, using MOD_PHP means that you cannot use the automatic update scripts.

  4. 2Niels
    Member
    Posted 4 years ago #

    Hi,

    WordPress newbie here working on my first site from last week. Tried si contact form on WordPress 2.9 and it worked fine.

    Updated to WordPress 3 yesterday and si contact form bombed.

    I deleted the old version of si contact form and attempted to upgrade to latest version though the WordPress Dashboard, but I've been unable to install it after 7 attempts. Other (unrelated) plugins have been upgraded successfully.

    Error messages vary but include 'cannot write folder public_html' and then 'Destination folder already exists. /public_html/wp-content/plugins/si-contact-form/'

    Any help greatly appreciated.

  5. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    You can FTP into your site and delete the /si-contact-form/ found in /public_html/wp-content/plugins/ folder.
    Then install it again. If you still get errors your server permissions are the cause.
    You can manually download the install zip file, unzip the files and upload the /si-contact-form/ folder and activate the plugin.

  6. 2Niels
    Member
    Posted 4 years ago #

    Thanks Mike.

    Have manually deleted the si-contact-folder and tried reinstalling both via WP interfce and downloading/uploading.

    No luck either way.

    Have checked permissions on the server and I have full read, write and execute permissions.

    Latest install error message (seem to be different every time):

    "Could not copy file. /public_html/wp-content/plugins/si-contact-form/captcha-secureimage/audio/P.wav"

    Other plugins seem to load/update OK?

  7. 2Niels
    Member
    Posted 4 years ago #

    Update...

    Manually deleted files from server and uploaded si-contact-form.zip directly to the server using the server's control panel (not via WordPress).

    Unzipped file on server in plugins folder and, hey presto, it works :o)

    Tried updating to v2.7.2 through WordPress, but same problems. Repeated above steps for the upgrade and, all works fine.

    Very handy, elegant and flexible form system, thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic