WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Webpage wont post- preview page shows old html site (8 posts)

  1. oilextech
    Member
    Posted 1 year ago #

    Hello,

    I am new to WordPress and slightly new to website design. I have made the page http://www.oilextech.com using html code only. I was recommended to use WordPress, however everything I have tried so far doesn't show the wordpress test site that I have made, it just shows the old html site I built. Under publish in the wordpress editor it says: status:published and visibility:public.
    I even tried deleting the files from the index for the old site. When I do this I get 404 error not found. How can I publish the page to be viewed by others. I tried following several video tutorials but they didn't seem to address this issue or have problems like this.

    Thanks,
    Jonathan

  2. AMEEKER
    Member
    Posted 1 year ago #

    Perhaps your WordPress installation ended up installed in a location other than the location this domain points to.

    Log into your WordPress installation, go to your Dashboard, then click on the tab in the left sidebar that says Settings, and then the link under that which says General.

    On that page you'll see two fields that say:
    WordPress Address (URL)
    Site Address (URL)

    What do the url's next to those say?

  3. oilextech
    Member
    Posted 1 year ago #

    Ameeker,

    Thanks for taking the time to help.
    WordPress Address (URL) http://oilextech.com
    site address (URL) http://oilextech.com

    Jonathan

  4. AMEEKER
    Member
    Posted 1 year ago #

    Ok. That's good. When you look at your website's files on your hosting account, when you look at the folder that contains your WordPress installation (or, if it's in the root of your public_html)...

    do you see something like this:
    http://www.angiemeekerdesigns.com/MISC/files.png

    You should have (among more files than just these) a wp-admin, wp-content, wp-includes, and then below those folders, you should still have an index.php file. If you have an index.html file here, it will display that instead of the index.php (which is your WordPress file). Can you take a look at that real quick? Or, if possible, post a screenshot of what those files look like for you?

  5. oilextech
    Member
    Posted 1 year ago #

    it includes all of my html website files along with:

    I do not see a index.php only index.html

    folders:
    stats
    wp-admin
    wp-content
    wp-includes

    .php files:
    wp-activate
    wp-app
    wp-blog-header
    wp-comments-post
    wp-config
    wp-cron
    wp-links-opml
    wp-load
    wp-login
    wp-mail
    wp-settings
    wp-signups
    wp-trackback
    xmlrpc

  6. AMEEKER
    Member
    Posted 1 year ago #

    Ok - so that's the issue.

    Did you use a one-click install of WordPress, or did you install yourself by downloading it here at WordPress.org?

    I'm asking because #1) we need to get a fresh copy of the index.php file from the latest version of WordPress, and add that back to that list of files there and #2) check to see if there are any other missing files from a fresh WordPress installation that should be there, but aren't. and #3) remove the index.html file. You can still keep it, just make a new folder, call is something like "Old Website" and move it out of this root folder.

    You can double check those files by downloading a copy of it from wordpress.org, unzipping that file, then just comparing what's in that file to what is in your list of files there. Don't replace any existing files - just add files that are missing.

    Does that make sense? We're FOR SURE adding the index.php file from a fresh download of WordPress, and any others that are missing there, too.

  7. oilextech
    Member
    Posted 1 year ago #

    Thank you for all your help,

    This is the solution to my problem, I downloaded wordpress via godaddy add-ons and it must not have installed the index.php because it would have overwritten my index.html.

    Thank you so much for resolving this issue!

    Jonathan

  8. AMEEKER
    Member
    Posted 1 year ago #

    No problem - have a good night.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.