WordPress.org

Ready to get started?Download WordPress

Forums

Weaver theme photo caption alignment issue (3 posts)

  1. jamminjames
    Member
    Posted 2 years ago #

    Hello,

    I'm trying out the Weaver theme, and love the ability to control a lot of things without messing with code. However, there are a few annoying problems, such as this:

    Using the "Reds" sub-theme (not sure if the same happens in other sub-themes), the caption for photos in a post is not aligned with the photo, it's a bit to the left and a bit too high (almost obscuring the caption under the photo).

    I've tried fiddling with the CSS, but can't get it to align. Any hints?

    (I have this site on my machine as a localhost setup, so I can't give you a url to look at.)

  2. jamminjames
    Member
    Posted 2 years ago #

    Ok, now I see it happens when I add vertical & horiz space in the advanced settings for the photo. With no space added, the theme is already adding white space around the photo, and around the post text, so I guess I don't need the extra space.

    So, only one problem remains: the caption is still too close vertically to the photo, bumping up against the bottom of it. How can I add a little padding there?

  3. jamminjames
    Member
    Posted 2 years ago #

    Found a solution that seems to work.

    In the \Main Options\Content Areas tab for the sub-theme, I added this to the Custom CSS styling under the "Captioned Image Border Color" line. (Hit the + mark to open up the custom styling box.)

    I discovered this margin was set to -20px elsewhere in the theme (found out using Firebug), putting this here adjusts it to -15px:

    #content .wp-caption p.wp-caption-text {
    margin-top: -15px;
    }

    Looks much better IMHO.

    Problem is, the relative distance seems to change with the size of the photo. On a small photo, the caption is pretty far below, on a medium size photo, it looks good, haven't tried it yet on a large one. Is there a way to set this where it is more relative?

    And what is it about the theme's settings that causes this problem? Finding an answer that addresses the root cause of the problem would, of course, be better.

Topic Closed

This topic has been closed to new replies.

About this Topic