WordPress.org

Ready to get started?Download WordPress

Forums

Wdiget problem (3 posts)

  1. leCLEMS
    Member
    Posted 1 year ago #

    Hi all

    We suddenly got a problem with the widget in wordpress.

    The page take a very long time to load and in the page none of the javascripts works.

    A PHP expert (not WP-expert) took a look at it and found that the page somehow 'time-out' in the widgets.php (mysite\wp-admin\includes\widgets.php).
    Line 192 :

    $has_form = call_user_func_array( $control['callback'], $control['params'] );

    the call_user_func_array() call the following :

    [callback] => widget_logic_extra_control
        [params] => Array
            (
                [0] => Array
                    (
                        [number] => -1
                    )
    
                [1] => jr_125ads-1
            )

    Look like the fact that the fact that the parameter is -1 is the problem.

    However what should we do ?

    Turn [number] => -1 to [number] => 1 ?
    Something else ?

    Thank you in advance for your help.

  2. Hi leCLEMS,

    It appears you may have a compatibility problem with the Widget Logic plugin if you've narrowed the problem down that far. I'd suggest posting over in their plugin support forum for additional help. You can visit their support section via this link: http://wordpress.org/support/plugin/widget-logic

  3. leCLEMS
    Member
    Posted 1 year ago #

    Thanks for you answer, will do.

Topic Closed

This topic has been closed to new replies.

About this Topic