WordPress.org

Ready to get started?Download WordPress

Forums

Watermark WP Image Protect
[resolved] Watermarks only show when lightbox or open the image (5 posts)

  1. sgsthebest
    Member
    Posted 10 months ago #

    Hi,

    Congratulations for this great plugin!
    It's the one I need because I want to have the option to change or remove completely watermarks without affecting the original images.
    Anyway, I have one problem. Watermarks only show when I open the images via lightbox, but not in the original size inside the posts. I've tried to low the threshold to 10, but no success. Also, the test image in admin panel does not show the watermark.

    Any idea, hint or clue about what may happen?

    Thanks and best regards

    http://wordpress.org/plugins/wp-image-protect/

  2. 8MediaCentral
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks for your kind words.

    You haven't included any url for me to look at so I'm going to do some guesswork. First of all have you cleared all the caches - server and browser, it seems newer versions of WordPress are particularly aggressive cache masters.

    Also ensure that images are served directly from your site, and not a CDN.

    If you need any more help, give me a shout, otherwise can you please mark the topic as resolved. Many thanks.

  3. sgsthebest
    Member
    Posted 10 months ago #

    Hi,

    Right now I have disabled the plugin until I find a solution, especially for Pinterest.
    I've tried to clear all the caches, etc...
    What I'm indeed using is a CDN (Cloudflare). Is this the explanation? But when I open the picture the watermark appears... Is it coherent with that?

    Is not there any chance to do it with Cloudflare?

    Thanks again and regards

  4. 8MediaCentral
    Member
    Plugin Author

    Posted 10 months ago #

    Yes, it's more than likely the CDN is the root of the issue. Have you tried hosting the images locally to see if this works?

  5. 8MediaCentral
    Member
    Plugin Author

    Posted 10 months ago #

    I'll mark this as resolved for the time being, unless I hear that you are still having trouble with images not coming from a CDN.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.