WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
Warnings on PHP 5.5 (3 posts)

  1. uelkfr
    Member
    Posted 10 months ago #

    Maybe it is due to I'm using too fresh version of PHP 5.5, but it would be good if it would be fixed.

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method GoogleSitemapGeneratorLoader::Enable() should not be called statically in /home/mysite/www/wp-includes/plugin.php on line 406 Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method GoogleSitemapGeneratorLoader::RegisterAdminPage() should not be called statically in /home/mysite/www/wp-includes/plugin.php on line 406 Strict Standards: Non-static method GoogleSitemapGeneratorLoader::GetBaseName() should not be called statically in /home/mysite/www/data/plugins/google-sitemap-generator/sitemap.php on line 114

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method GoogleSitemapGeneratorLoader::CallHtmlShowHelpList() should not be called statically in /home/mysite/www/wp-includes/plugin.php on line 173 Strict Standards: Non-static method GoogleSitemapGeneratorLoader::GetBaseName() should not be called statically in /home/mysite/www/data/plugins/google-sitemap-generator/sitemap.php on line 199

    http://wordpress.org/plugins/google-sitemap-generator/

  2. uelkfr
    Member
    Posted 10 months ago #

    I have also checked different pages in admin panel. Maybe you have too much hooks, because your warnings are everythere. Try to turn WP_DEBUG = true under WordPress 3.6.1. On Plugins page they are on front of each of plugin.

  3. kjmtsh
    Member
    Posted 9 months ago #

    Hi, uelkfr

    Set WP_DEBUG to false and instead use below setting in your wp-config.php.

    error_reporting( E_ALL ^ E_STRICT );

    This will make the error reporting as before. If you want WP_DEBUG_DISPLAY, use below.

    ini_set( 'display_errors', 1 );

    And if you want to use WP_DEBUG_LOG, use below.

    ini_set( 'log_errors', 1 );
    ini_set( 'error_log', 'your log file directory/log file name' ); // don't use WP_CONTENT_DIR

    This is only a workaround to suppress E_STRICT warnings, but the settings above are exactly the same as PHP 5.3.x. See also http://php.net/manual/en/function.error-reporting.php

    Good luck.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.