WordPress.org

Ready to get started?Download WordPress

Forums

"Warning: Unable to access" errors on install.php (11 posts)

  1. John_C
    Member
    Posted 8 years ago #

    Hello,

    I am trying to install WordPress on a Solaris OS and Apache 1.3.27. I have downloaded WordPress 2.0 and added the proper information to the wp-config.php. Whenever I try to access the install.php page I get the following warnings that appear before the text of the install page:

    Warning: Unable to access /usr/local/apache/apache_home/htdocs/wordpress/wp-content/cache/ in /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/cache.php on line 360

    Warning: Unable to access /usr/local/apache/apache_home/htdocs/wordpress/wp-content/cache/c4ca4238a0b923820dcc509a6f75849b/options/3a995577da2e40d463313aece14b6f6b.php in /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/cache.php on line 130

    Warning: Unable to access /usr/local/apache/apache_home/htdocs/wordpress/wp-content/cache/c4ca4238a0b923820dcc509a6f75849b/options/725b5f8b2872003a9512418fc1b7c1a3.php in /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/cache.php on line 130

    Warning: Unable to access /usr/local/apache/apache_home/htdocs/wordpress/wp-content/cache/c4ca4238a0b923820dcc509a6f75849b/options/82793f79ca5d5f48daa6f4c334b85589.php in /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/cache.php on line 130

    Warning: Unable to access /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/languages/en_US.mo in /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/wp-l10n.php on line 71

    Warning: Cannot add header information - headers already sent by (output started at /usr/local/apache/apache_home/htdocs/wordpress/wp-includes/cache.php:360) in /usr/local/apache/apache_home/htdocs/wordpress/wp-admin/install.php on line 16

    I have given 755 rights to everything in the wordpress folder.

    I can continue with the install, but these errors appear on the first pages of the installation and I have not gone any further than that. I would like to get this problem solved before I continue with the installation.

    If anyone has seen anything like this before, I would appreciate any help or suggestions you could provide.

    Thanks for your time.

  2. MichaelH
    Member
    Posted 8 years ago #

    For now, try 777 on wp-content to see if that makes a diff.

    ********************
    Welcome to the WordPress Support Forums!

    Please help keep the Forums successful by reading:
    Using the Support Forums

    Also, remember the WordPress Codex and the FAQ pages.

    And, thank you, for letting us know if this information proves useful (or not)!
    ********************

  3. John_C
    Member
    Posted 8 years ago #

    MichaelH,

    Unfortunately, I get the same results when I give 777 to wp-content. I also did the same for wp-includes without any success.

    Thanks for your time.

    John

  4. MichaelH
    Member
    Posted 8 years ago #

    What version of PHP?

  5. John_C
    Member
    Posted 8 years ago #

    PHP Version 4.2.3

    I also have Safe Mode enabled. I am not sure if this would make a difference. I thought I had read that Safe Mode should not matter.

    John

  6. MichaelH
    Member
    Posted 8 years ago #

    Read this hackers thread--seems it might be relevant:
    http://comox.textdrive.com/pipermail/wp-hackers/2006-January/004210.html

    clipping info from that hackers thread for subsequent searches in Forums:

    Update: That is NOT a reliable method of setting ABSPATH because it breaks wp-admin. ABSPATH must be hardcoded for the blog to start to work. Any other place __FILE__ is used will still be broken.

    Their server is a Sun running php 4.2.3. There is a serious bug with __FILE__ on that platform, wherein that magical constant does not include the absolute path when located under ~. It has been reported to work correctly under the Apache root. I think it is unreasonable to require WordPress to work around that bug.

    http://bugs.php.net/bug.php?id=13936
    http://bugs.php.net/bug.php?id=27823

  7. John_C
    Member
    Posted 8 years ago #

    Thanks for the link. I will look into this and get back to you with the results. Thanks for the prompt responses as well.

    Thanks for your time.

    John

  8. kkarner
    Member
    Posted 8 years ago #

    Try starting from the beginning of the installation. When you downloaded the WordPress program it might have had a problem and not downloaded correctly.

  9. John_C
    Member
    Posted 8 years ago #

    kkarner,

    Yes that is a good idea as well. I will give that one a try and get back to everyone. Thanks for the good suggestions.

    John

  10. John_C
    Member
    Posted 8 years ago #

    MichaelH,

    I have read through your suggested forums. They all seem to talk about __FILE__ not returning the absolute path in certain locations with my version of PHP under Solaris.

    I have created the test files as it suggests in http://bugs.php.net/bug.php?id=13936

    These files were created under the Apache root, and also within the wordpress directory. An absolute path is returned in both places. It does not seem that I am suffering from this bug.

    I have also tried to download the installation again, to eliminate the possibility of any errors/problems with the initial download and got the same results.

    Thanks for your time.

    John

  11. John_C
    Member
    Posted 8 years ago #

    Good news everyone,

    It was pointed out to me that there was a new version recently made available (2.0.1). I have installed this version, and after a small problem with permissions on the wp-includes directory, everything worked!

    2.0.1 seems to be working great so far. Now we just have to do a little testing to make sure all is well.

    Thanks for all of your help.

    John

Topic Closed

This topic has been closed to new replies.

About this Topic