WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
Warning: session_start() (7 posts)

  1. Lane Lester
    Member
    Posted 1 year ago #

    I'm using BackWPup with success on a number of sites, but this one is on a separate server from most of my sites. In the admin section, the following is displayed at the top of the BackWPup page:

    Warning: session_start() [function.session-start]: open(/home/clarkesvillelibrary.org/tmp/sess_af3d42d9143e20ce4bcddf8e4e3c6895, O_RDWR) failed: Permission denied (13) in /home/clarkesvillelibrary.org/public_html/wp-content/plugins/backwpup/inc/class-admin.php on line 250
    
    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/clarkesvillelibrary.org/public_html/wp-content/plugins/backwpup/inc/class-admin.php:250) in /home/clarkesvillelibrary.org/public_html/wp-content/plugins/backwpup/inc/class-admin.php on line 250
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/clarkesvillelibrary.org/public_html/wp-content/plugins/backwpup/inc/class-admin.php:250) in /home/clarkesvillelibrary.org/public_html/wp-content/plugins/backwpup/inc/class-admin.php on line 250

    Lane

    http://wordpress.org/extend/plugins/backwpup/

  2. tincanranch
    Member
    Posted 1 year ago #

    I just had something similar happen when my hosting had to move me from one server to another. My issue was caused by permissions not set correctly on that /tmp directory on my new server.

    Maybe this'll help someone (I find answers in the forums all the time, but never really get to give back).

    I hope it helps!

  3. wp-mistress
    Member
    Posted 1 year ago #

    Hi,

    I am facing the same problem. However, the problem is present on some installations but not others on the same server. I had a look at my /tmp directory permissions - but couldn't see any differences. I did notice that the plugin now uses two temp directories instead of the earlier 1 (in previous versions before the last couple of updates).

    Could you be a little more specific about what you did to fix the permissions?

    Thanks

  4. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    did you have test Version 3.0.7?

    There i have set the BackWPup temp dir for sessions temp dir if the default issend writeable.

  5. wp-mistress
    Member
    Posted 1 year ago #

    Hello,

    Yes, I have version 3.0.7.

    As a follow up, on further investigation I found that once I activated the plugin, and visited the Settings -> Information section, the plugin resumed working without a problem and the warning messages disappeared. I was checking if Safe mode was on - as one of the support threads suggested as much - but found that was not the case.

    Not sure why this resolved the problem - but I could replicate it on a couple of sites. Hope this helps you investigate and resolve it.

    Thanks

  6. tincanranch
    Member
    Posted 1 year ago #

    Hello again,

    Just my followup info... I don't believe my issue was specific to this plugin, but is what brought the issue to the surface -- unless using that /tmp is a flaw.

    As you see it the original poster's Warning msgs above, /tmp is at the same level as his /public_html, I had a similar situation. We don't have access ourselves above our 'root' (the /html dir) so I could not check permissions myself, I was at the mercy of the hosting service.

    After 45mins on the phone with the first level support, I was finally able to get them to bump up a level in the service chain and they discovered that permissions were not set properly.

    Hope it helps.

  7. NihilLab
    Member
    Posted 7 months ago #

    hello i have the similar problem

    Warning: session_start() [function.session-start]: open(C:\Windows\Temp\\sess_fgstfchr102geqkcmp0jgn2da5, O_RDWR) failed: Invalid argument (22) in D:\Hosting\12111878\html\nihil\wp-includes\plugin.php on line 429

    line code

    // Sort
    if ( !isset( $merged_filters[ $tag ] ) ) {
    ksort($wp_filter[$tag]);
    $merged_filters[ $tag ] = true;
    }

    reset( $wp_filter[ $tag ] );

    do {
    foreach ( (array) current($wp_filter[$tag]) as $the_ )
    if ( !is_null($the_['function']) )
    call_user_func_array($the_['function'], array_slice($args, 0, (int) $the_['accepted_args']));

    } while ( next($wp_filter[$tag]) !== false );

    array_pop($wp_current_filter);
    }

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.