WordPress.org

Ready to get started?Download WordPress

Forums

CopySafe Web Protection
[resolved] warning: scandir (...) line 284 286 (7 posts)

  1. cfbakker
    Member
    Posted 6 months ago #

    Hi,

    My client wants to protect the images on the website, so I installed the Copysafe Web Plugin. But it keeps giving me the same error/warning:

    <b>Warning</b>: scandir(/home4/[...]/wp-content/uploads/copysafe-web/): failed to open dir: Permission denied in <b>/home4/[...]/wp-content/plugins/wp-copysafe-web/function.php</b> on line <b>284</b>

    <b>Warning</b>: scandir(): (errno 13): Permission denied in <b>/home4/[...]/wp-content/plugins/wp-copysafe-web/function.php</b> on line <b>284</b>

    <b>Warning</b>: Invalid argument supplied for foreach() in <b>/home4/[...]/wp-content/plugins/wp-copysafe-web/function.php</b> on line <b>286</b>

    Changing the permission for the file didn't do the trick.

    How to fix this?

    Kind regards,

    Charlotte

    http://wordpress.org/plugins/wp-copysafe-web/

  2. ArtistScope
    Member
    Plugin Author

    Posted 6 months ago #

    "Permission denied" sums it up. You may have changed permissions but you need full permissions, ie: read, write and

      execute
    for everyone.

  3. cfbakker
    Member
    Posted 6 months ago #

    Yes, I changed permissions for function.php to 777, that is read, write and execute for everyone. Still keeps giving me the same warning. So what to do know?

    Kind regards,
    Charlotte

  4. ArtistScope
    Member
    Plugin Author

    Posted 6 months ago #

    The read, write and execute permissions for everyone need to be applied to the upload folder.

  5. Icicleta
    Member
    Posted 6 months ago #

    I have the same problem, I changed permission to the folder of upload and all the subfolders and files to 777 and for everyone. Still same problem.

    Any other idea?

    Many thanks

  6. esmi
    Forum Moderator
    Posted 6 months ago #

    @Icicleta: If you require assistance then, as per the Forum Welcome, please post your own topic.

    This topic references an old version of WordPress.

  7. ArtistScope
    Member
    Plugin Author

    Posted 6 months ago #

    Try setting permissions to read, write and EXECUTE for everyone.

    Note that I specify "EXECUTE" because some control panels can overlook this.

Reply

You must log in to post.

About this Plugin

About this Topic