WordPress.org

Ready to get started?Download WordPress

Forums

Warning: Sabre not yet compatible w WP3 Multi Site (Network) Feature (5 posts)

  1. DougJoseph
    Member
    Posted 4 years ago #

    Sabre is a great plugin, and the author has indicated he feels it is compatible with WP3 in "mono" mode (without Multi Site activated). See this page: http://wordpress.org/support/topic/389051?replies=2

    On that same thread, the plugin's developer (Didier) also tells that he is not yet supporting the Multi Site (Network) Feature of WP3.

    I was using Sabre in 3.0 before I turned on 3.0's Multi Site (Network) feature. I turned on the Multi Site feature before I knew that Sabre was not compatible, and (honestly) without really considering whether Sabre would be compatible. I just wanted to give you all a heads up:

    I created a new site on the network. Then I added my main Admin account as a user on that new site. Not sure if I was supposed to do that (I am real green on this). Anyhow, that action somehow deleted the Admin account's "OK" status in Sabre (it lost its valid user status). I can no longer log in with that account. Luckily I had a backup account with Admin status also, with which I can still log in.

    When I click into that main Admin user account, its confirmation status (at the bottom of the page, where the Sabre stuff is shown) shows empty.

    Here's where it gets interesting: I tried to manually confirm that account, to get it to be valid again, and Sabre gave me this reply:

    WordPress user doesn't need to confirm registration. Manual registration ineffective.

    So, somehow Sabre knows it is confirmed (on one hand), but at login time Sabre does not know it is confirmed (on the other hand).

    I guess I will try to edit the MySQL table(s) manually to get the account valid again. Any advice on that would be appreciated, but not expected, as I know the developer is not supporting this aspect.

    -Doug Joseph

    http://wordpress.org/extend/plugins/sabre/

  2. danatstadiumvolleyball
    Member
    Posted 4 years ago #

    Agree - not working with multisite.

  3. dlo
    Member
    Posted 3 years ago #

    You're right. As already mentioned, Sabre 1.1.2 is currently not compatible with WordPress 3.0 in multisite mode.

    I have plans to make it operational in a multisite configuration as well as usable with BuddyPress.

    But first of all, I have to dive into the multisite stuff and coding and install a multisite sandbox as this aspect of WordPress is totally new to me. My summer school work, no ?

    So rest assure that Sabre is going to evolve in a near future.

    Best regards,
    Didier

  4. asshu
    Member
    Posted 3 years ago #

    I installed sabre for my multisite. All the children sites are having this error "Warning: extract() [function.extract]: First argument should be an array in/......../wp-content/plugins/sabre/classes/sabre_class.php on line 457 .

    I understand that it will not work for children sites .Can I still use it for my main site?

    Thank you !

  5. Luke Gedeon
    Member
    Posted 3 years ago #

    @Didier I have a multi-site test install you are welcome to practice on and I have spent a lot of time on Multisite, so I might be able to help a bit.

    Message me, if I can help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags