WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Warning - reset Nextgen options breaks site (16 posts)

  1. programmin
    Member
    Posted 2 months ago #

    I found a significant bug in the latest Nextgen 2.0.66: On some sites at least, you can break the site by resetting Nextgen options (going to any page of the site will show the correct url, but actually show the site's homepage html).

    Adding in the missing router_param_slug=nggallery makes the site show pages other than the homepage. Adding in correct mvc_template_dirname and mvc_static_dirname options makes it so you can actually see the options settings page for Nextgen on wp-admin... but to actually show galleries on pages you must copy the full serialized array from similar working site.

    I hope this issue gets fixed soon - I think I remember hearing of similar behavior in the 1.x Nextgen as well.

    Btw is there any documentation on what the options in this ngg_options serialized array are?

    https://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 2 months ago #

    @programmin - NextGEN Gallery version 2.0.66 was a security release to specifically limit the file types you are able to upload (as was version 2.0.65).

    If using the Reset Option under Gallery > Other Options is "breaking" your site then there was most likely some other issue at hand that was actually causing the problem, and in most of those cases we ask that a Bug Report (http://www.nextgen-gallery.com/report-bug/) is submitted so we are fully aware of the issue and we offer the external Reset Tool plugin which works very similar to the Reset Option but "fixes" anything that may get broken in it.

    As to documentation specifically covering the "ngg_options serialized array", there is nothing specifically available but we were actually discussing that documentation requirements (both internal and external) will need to be made a higher priority with the latest modifications and enhancements we are working on and planning to add.

    Thanks for the suggestion.

    - Cais.

  3. ajp55
    Member
    Posted 1 month ago #

    Hi!
    Thank you for this great plugin.
    but i'm still having this problem wp-content\plugins\nextgen-gallery\products\photocrati_nextgen\modules\nextgen_gallery_display\no_images_found.php is not a valid MVC template

    is not a valid MVC template.
    Don't know what to do know. Can Someone helps me?

  4. photocrati
    Member
    Plugin Author

    Posted 1 month ago #

    @ajp55 - You should start your own topic for your own issue(s) ... in this case please follow the link above for Bug Reports and ask us for the external Reset Tool plugin. It may be what you need to get this sorted out.

    Thanks!

    - Cais.

  5. ajp55
    Member
    Posted 1 month ago #

    @Author.
    Why don't you make the external Reset Tool plugin just available to your website. So we can just download it instead of following a link and submitting a Bug Reports?
    I'm not the first to get this kind of error about MVC template.
    You are doing a great work and thank you.

    ----Sorry for my English, my native language is not English---

  6. photocrati
    Member
    Plugin Author

    Posted 1 month ago #

    @ajp55 - The Bug Report also helps us to keep track of what issues are being seen ... if we simply made the Reset Tool public we would not have any data to tell us under what circumstances it was needed (there are a few issues that it generally resolves), but thank you for your suggestion we have considered it in the past.

    - Cais.

  7. ajp55
    Member
    Posted 1 month ago #

    @Author!!!
    I have already submitted the bug report, but I have not yet received the Reset Tool.
    Is there anything I have to do again, or simply expecting it in my mail.
    Thanks

  8. photocrati
    Member
    Plugin Author

    Posted 1 month ago #

    @ajp55 - You should have received the Reset Tool in a response from the Bug Reports conversation.

    - Cais.

  9. ajp55
    Member
    Posted 1 month ago #

    You should have received the Reset Tool
    I have not received any response from the Bug reports I submitted.
    Should I wait again.
    I really want to use your plugin, but it's delaying my work now.
    Should I submit another Bug reports? Since nobody has responded.

  10. ajp55
    Member
    Posted 1 month ago #

    @Author

    You should have received the Reset Tool
    I have not received any response from the Bug reports I submitted.
    Should I wait again.
    I really want to use your plugin, but it's delaying my work now.
    Should I submit another Bug reports? Since nobody has responded.

  11. photocrati
    Member
    Plugin Author

    Posted 1 month ago #

    @ajp55 - Yes, I just finished reviewing the open Bug Reports and there are none that have not been addressed/replied to.

    Here is the link again, just in case: http://www.nextgen-gallery.com/report-bug/

    Thanks!

    - Cais.

  12. programmin
    Member
    Posted 1 month ago #

    Why is the "Reset" in the other-options of Nextgen not this tool?

    Especially when the built-in reset has been known to break things, the reset-plugin is known to fix things and does a good job.

  13. photocrati
    Member
    Plugin Author

    Posted 1 month ago #

    @programmin - The Reset Tool does the same thing as the Reset Option. Functionally there is no difference between the two. There are simply cases when the Reset Option is not available, for whatever reason, so we offer the Reset Tool in those cases.

    Thanks!

    - Cais.

  14. ajp55
    Member
    Posted 1 month ago #

    @Author.
    I finally received the Reset Tool in my box, but it's not doing anything after installing it.
    Shoud I uninstall the next-gallery plugin first? Please, what is the order?
    Removing everything, because, i'm not getting the Menu that's supposed to pop out when hovering over plugin Gallery. I'm just getting Manage Tags as the first sub-menu. Where are they other submenus?
    Thanks

  15. ajp55
    Member
    Posted 1 month ago #

    @Author:
    I just checked the database, no table concerning next-gallery plugin.
    Is it correct?

  16. photocrati
    Member
    Plugin Author

    Posted 1 month ago #

    @ajp55 - IF you are only seeing the "Manage Tags" menu item then there is most likely a plugin conflict / permissions issue at play.

    Deactivate *all* plugins. Reactivate NextGEN Gallery. Reactivate NextGEN Gallery Reset. Now, use the Reset Tool *twice* under Tools > NextGEN Gallery Reset.

    If you are not seeing any tables in the database with *_ngg_* in them, that would be a completely different issue and not related to the Reset Option/Tool in any way.

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.