WordPress.org

Ready to get started?Download WordPress

Forums

Warning: require_once - got a warning after installing a theme (5 posts)

  1. Anne Vium
    Member
    Posted 1 year ago #

    I got this warning after having installed the theme "canyon":

    Warning: require_once(/home/www/floejene.mortenvium.dk/wp-content/themes/canyon/lib/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/floejene.mortenvium.dk/wp-content/themes/canyon/functions.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required '/home/www/floejene.mortenvium.dk/wp-content/themes/canyon/lib/init.php' (include_path='.:/php/includes:/usr/share/php') in /home/www/floejene.mortenvium.dk/wp-content/themes/canyon/functions.php on line 3

    It surprised me, as the theme seems to be a much used one.
    Does anyone know what could have caused this warning, and what i can do to make it go away? The entire server is down. Help would be much appreciated :-)

  2. ahuggins
    Member
    Posted 1 year ago #

    Where did you get the theme from? I would start by contacting the company you got the theme from. They would know more about it than anyone.

    If you got it from off the internet somewhere, there is a good chance you installed a theme with potentially malicious code in it. If you can FTP to your account, I would delete it as soon as possible. If you do not have FTP access, contact your host and see if they can do anything.

  3. ahuggins
    Member
    Posted 1 year ago #

    Are you running this on a localhost?

  4. Anne Vium
    Member
    Posted 1 year ago #

    It is downloaded on wordpress.org.
    I can't FTP to my account.
    Thank you, I guess I'll try that :-)

  5. Anne Vium
    Member
    Posted 1 year ago #

    Im not sure if it's localhost?

Topic Closed

This topic has been closed to new replies.

About this Topic