WordPress.org

Ready to get started?Download WordPress

Forums

Warning: Require_Once (5 posts)

  1. cowlesk
    Member
    Posted 3 years ago #

    At first, my home page stopped working but I was able to go through the files and deleter any extra code and it now works.

    However, I am still unable to login to my wordpress site and I get this warning message:

    Warning: require_once(./admin.php) [function.require-once]: failed to open stream: No such file or directory in /home/cowlesk/public_html/freecarpetnews.com/wp-admin/index.php on line 10

    Fatal error: require_once() [function.require]: Failed opening required './admin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cowlesk/public_html/freecarpetnews.com/wp-admin/index.php on line 10

    Online 10 of wp-admin/index/php it says:

    require_once('./admin.php');

    Any idea how I can fix this?

  2. What code did you delete? Was it theme code or WordPress core code?

    I would delete the theme folder (after backing it up) and ONLY have twentyten in wp-content/themes - that will default your site back to the Twenty Ten theme.

  3. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    do you have the admin.php file in the wp-admin folder?

  4. cowlesk
    Member
    Posted 3 years ago #

    No, admin.php is not in the wp-admin folder.

    I deleted any extra spaces or lines at the end of each php file but did not delete any actual code.

    I removed the folders that were in the wp-content/themes folder so that only the Twenty Ten theme is left but it did not help.

    What exactly do you mean by deleting the theme folder?

  5. No, admin.php is not in the wp-admin folder.

    Well. That would be a problem.

    Go to http://wordpress.org/download/

    Download WordPress.

    Copy everything up.

Topic Closed

This topic has been closed to new replies.

About this Topic