WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
Warning on debug mode with new WP 3.6 (4 posts)

  1. Juergen Schulze
    Member
    Posted 1 year ago #

    Strict Standards: Declaration of PageNavi_Options_Page::validate() should be compatible with scbAdminPage::validate($new_data, $old_data) in C:\temp\UniServer\www\xxx\wp-content\plugins\wp-pagenavi\admin.php on line 156

    http://wordpress.org/plugins/wp-pagenavi/

  2. kjmtsh
    Member
    Posted 1 year ago #

    Hi, Juergen.

    I've got the same notice. This is a workaround.

    wp-pagenavi/scb/AdminPage.php (line 142)

    function validate( $new_data, $old_data = null ) {

    wp-pagenavi/admin.php (line 15)

    function validate( $options, $old_data = null ) {

    The line numbers may be different from one version to another.
    The PHP notice will disappear, I guess.

    Good luck!

  3. Juergen Schulze
    Member
    Posted 1 year ago #

    Thanks for the hint.
    But I'd rather wait for an official fix.
    Or do you think that there will be never one?

  4. kevinhaig
    Member
    Posted 1 year ago #

    Hi kjmtsh

    I put in a request for a fix quite a while ago but nothing so far.

    The author's probably busy earning a living or something crazy like that :)

    Thanks for the workaround.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.