WordPress.org

Ready to get started?Download WordPress

Forums

Warning on activating theme (7 posts)

  1. jamesgangcreative
    Member
    Posted 2 years ago #

    On upload of a theme I'm getting these messages:

    Warning: fopen(home/content/n/r/g/nrgxxxxxxx/html/theURLName/wp-content/themes/organic_tech_theme1/style.css0 [function.fopen]: failed to open stream. No such file or directory in home/content/n/r/g/nrgxxxxxxx/html/theURLName/wp-includes.functions.php on line 4339

    Warning: fread(): supplied argument in not a valid stream resource in /home/content/.…on line 4342

    Warning: fread(): supplied argument in not a valid stream resource in /home/content/.…on line 4345

    ...even though the message above it says "Theme uploaded correctly" Upon continuing I get the message:

    Active Theme is broken.

    How do I fix this?

    Also, I get something similar from another theme on a different site when I post POSTS.

    Both of these sites are on GoDaddy using their one step application.

  2. govpatel
    Member
    Posted 2 years ago #

    using ftp First switch back to default theme by renaming the theme you just installed and see if you are having problem if it all works fine then the problem is theme related and may not be compatible with wordpress version you using

  3. jamesgangcreative
    Member
    Posted 2 years ago #

    Not sure I'm following. You are saying I need to do something either via the GoDaddy FTP or Fetch vs. doing anything with switching the themes in WordPress?

    I've just spent quite a few hours on building the other site; the theme was purchased from a 3rd party and they assure me it's fine.

  4. govpatel
    Member
    Posted 2 years ago #

    As is you are not able to log in admin as you have error in theme you installed so by renaming the theme in themes folder you are forcing wordpress to open default theme.

    Once you have admin panel working with default theme then may be you have not installed theme properly

    the theme was purchased from a 3rd party and they assure me it's fine

    Did you unzip the folder and check if there are other files and folders in zip file as there may a themes folder in there and you need to upload the content of that folder in themes folder.

  5. jamesgangcreative
    Member
    Posted 2 years ago #

    I can log into the admin panel fine. I see the default theme.
    I can't install the new theme.
    I didn't unzip the folder. I just chose to load the zip file directly. I will look at see if there is something else in there.

  6. govpatel
    Member
    Posted 2 years ago #

    The reason I said that is when you bought the theme most likely it is bundled with other files and folder and when you upload the zip as is you get error

  7. jamesgangcreative
    Member
    Posted 2 years ago #

    Yes, thank you. That was the error. It turns out there was a black and a white theme. Now, I have to figure out why the posting isn't working in another matter, but is still same type of warning. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic