WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Warning: Invalid argument supplied for foreach() after plugin upgrade on v.2 (10 posts)

  1. B_Dark
    Member
    Posted 12 months ago #

    I got this msg :

    Warning: Invalid argument supplied for foreach() in /home/****/public_html/wp-includes/query.php on line 1702

    after upgrade you plugin on my multisite , i tried to make update on /wp-admin/network/admin.php?page=nextgen-gallery

    And i got this msg too:

    Warning: Cannot modify header information - headers already sent by (output started at /home/*****/public_html/wp-includes/query.php:1702) in /home/*****/public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/frame_communication/class.frame_event_publisher.php on line 67

    how can i fix this?

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    Multi-site is a huge priority for us. Because legacy versions of NextGEN (1.9.x) were only partially compatible, we were not able to finish completing the code for full compatibility in v2.0 for multi-site but we do have that on our agenda for one of the next upgrades.

    --Becky

  3. B_Dark
    Member
    Posted 12 months ago #

    Thnx for the fast response . i roll back to 1.9.13. waiting the new update for multisite :)

  4. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @B_Dark - No problem. We hope to have that out soon! If you need help with how to roll back a version, we have a help doc here: http://www.nextgen-gallery.com/how-to-rollback-a-version/

    Hope that helps!
    -Becky

  5. vimo
    Member
    Posted 12 months ago #

    Becky,
    thanks a lot from my side as well... I upgraded to 2.0 with a database backup but (of course...) having forgotten to backup the server files.
    Got the same error messages as B_Dark. Thanks to your help doc I managed to roll back to 1.9.13 within a few minutes - despite normally being IT-illiterate. Highly appreciated!

  6. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @vimo and @B_Dark: While NG isn't completely mulitsite compatible (Legacy 1.9.x wasn't either), you should be able to activate on a mutlisite-enabled WordPress instance, and you should be able to use it fine on the main blog. Are you able to do that, or are the errors above preventing activation? If so, that may be a separate issue.

    Thanks!
    Erick

  7. netmorix
    Member
    Posted 12 months ago #

    I've got the same problem. After updating to 2.0.0 on a multisite installation, i get the same error message concerning line 1702 in the query php.

    my workaround was to put if ( is_array( $GLOBAL['wp-taxonomies'] )) around the foreach loop. But the problem itsself is caused by NG. Could you please fix it. The error message is visible on the frontend and backend...

    We get a lot of trouble with our customer...

  8. B_Dark
    Member
    Posted 12 months ago #

    from my side, i activated from main network /wp-admin/network/plugins.php
    and shows me this error

  9. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    Thanks for the update and sharing your workaround @netmorix & @B_Dark. Please know that we are working rapidly towards multisite compatibility and will hopefully reach a working solution soon. If you're seeing errors with v2.0, you might consider rolling back to v1.9.13 until we are multisite compatible. See: http://www.nextgen-gallery.com/how-to-rollback-a-version/

    Hope that helps!
    -Becky

  10. fran330
    Member
    Posted 11 months ago #

    Same error for me on multisite. As you said above, Photocrati, it works on the main site if only activated on main site. But it's not working on sub sites when activated on them.

    I am glad you said that you are working towards multisite full compatibility because more and more WP web designers build only multisites. That's my case - If not for immediate multilingual needs, a client might need a sub site anytime. It's much more convenient to build a multisite from the start rather than converting a single site to a multisite.

    Thanks to the Photocrati team for your attention to this thread,
    Fran

Reply

You must log in to post.

About this Plugin

About this Topic