WordPress.org

Ready to get started?Download WordPress

Forums

Warning: in_array() [function.in-array]: Wrong datatype for first argument in .. (16 posts)

  1. Fabrizio Pivari
    Member
    Posted 4 years ago #

    I've just installed to test 3.0 beta 2 and everything seems to work good but when I want to see a post e.g.
    http://www.pivari.com/video/giudice-di-pace-online-lo-stato-del-procedimento/
    I can see correctly the page but the error is
    Warning: in_array() [function.in-array]: Wrong datatype for first argument in /usr/local/share/doc/vhost/pivari.com/httpdocs/wp-includes/canonical.php on line 180

    Suggestion?

  2. Do you get this error using another theme?

  3. Fabrizio Pivari
    Member
    Posted 4 years ago #

    I've tried with Arthemia 1.0, iBlue, WordPress Classic 1.5 and Twenty Ten 1.0 and I have the same error.

    Fabrizio

  4. 1) Are you sure you uploaded everything when you upgraded?

    2) What plugins are you using?

  5. Fabrizio Pivari
    Member
    Posted 4 years ago #

    1) I've deleted wp-admin and wp-includes and I've copy over the new installation. Then I made upgrade db

    2) I had the same problem with my site http://www.payperaction.us/
    This is a "test" site and has less plugins

    The plugins I use are

    All in One SEO Pack
    Contact Form 7
    Google XML Sitemaps
    One Click Plugin Updater
    Really Simple CAPTCHA
    WordPress Database Backup

    I re-install 2.9.2 and everything works good.
    If you need I can re-install 3.0 beta2 and give you an admin user to see inside.

    fabrizio (at) pivari dot com

  6. That's really weird. I have two sites on 3.0-beta2 without errors.

    Can you try the latest nightly? http://wordpress.org/download/nightly/ Maybe they've fixed it.

  7. Fabrizio Pivari
    Member
    Posted 4 years ago #

    The latest nightly doesn't fix the problem
    http://www.payperaction.us/maleva/distribuzione-comunicati-stampa/

  8. Fabrizio Pivari
    Member
    Posted 4 years ago #

    I deactivate every plugin and use a default thema and nothing changes.
    I think I was wrong in the update o there is something strange in the db.

    I've php 4 and old mysql.

  9. WP needs PHP 4.3 and MySQL 4.1.2

    Check if you have those?

  10. AaronPowell
    Member
    Posted 4 years ago #

    I've ran into exactly the same problem. Weird thing was, I'm running 3.0 on two different sites and I see it on one, but not the other. Then I realized that my server was setup to use PHP 4 on one domain and PHP 5 on the other. It was the site running 4 that had the error message. I switched it to 5 and the message went away.

  11. Fabrizio Pivari
    Member
    Posted 4 years ago #

    I can't switch to PHP 5 :(
    Can you fully support PHP 4?

  12. Which version of 4 are you using?

    If it's less than 4.3, you're out of luck.

  13. Fabrizio Pivari
    Member
    Posted 4 years ago #

    ISP tells me php 4.4!

    :)

  14. Okay, that should work, and if not, it should ping when you try and upgrade.

    Raise an issue in the Trac: http://codex.wordpress.org/Reporting_Bugs

  15. I've committed what I believe is a fix for this to make the new code PHP4 compatible and this will be available in the next nightly build to test out.

    The version number for that build will be 3.0-beta2-14697

    Please report back on the ticket how you get along with this.

    Cheers

  16. Usman Latif
    Member
    Posted 4 years ago #

    I had the same problem. Its now resolved after upgrading to the latest beta version.

    Thanks Westi.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags