WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
Warning: in_array() expects parameter 2 to be array ... (10 posts)

  1. klingonio
    Member
    Posted 1 year ago #

    Hello,

    please check this Failure. Do you can fix it?

    If you call the category from a event:
    Warning: in_array() expects parameter 2 to be array, null given in /www/htdocs/v160263/aza/wp-includes/post-template.php on line 1039

    witch best regards

    Ingo

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hi Ingo. Thanks for the report here; this is an odd issue and not one I'm seeing on my end. Are you saying you get this whenever you click into a category from an individual event? If so, mind posting a link to your site so I can check it out in action?

    Thanks in advance!

  3. klingonio
    Member
    Posted 1 year ago #

    Hello,

    yes it is so.

    Here my Calendar event: "http://aza.astronomie-klingonio.de/?tribe_events=beobachtung-des-kometen-c2011-l4-panstarrs"

    and then klick on "Kategorie: Beobachtungsabende"

    Here the link: "http://aza.astronomie-klingonio.de/?tribe_events_cat=beobachtungsabende"

    ... or other event ...

    Ingo

  4. klingonio
    Member
    Posted 1 year ago #

    sorry my english is not so good :-(

  5. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Ah, no problem about the English! Thanks for confirming - I understand now.

    Try enabling a pretty permalinks structure, something like /%postname%/, and retest on the frontend (you may need to clear your cache). That should clear this up for you...but please let me know if not.

  6. klingonio
    Member
    Posted 1 year ago #

    ok, i set the permalink structur "/%year%/%monthnum%/%day%/%postname%/".
    Then i cleared all caches and tested with all categories.
    But the Error is not cleared ... :-(

  7. la79
    Member
    Posted 1 year ago #

    Just got a warning: in_array error also. I get this when I try to view in "Calendar" or "Event List" view on my website.

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /wp-includes/post-template.php on line 1039

    Plugin version 2.0.10 was working fine but 2.0.11 is not. Also I updated to WordPress 3.5.1 and it's still the same.

    Tried to update permalink structure and still the same. Ideas?

  8. klingonio
    Member
    Posted 1 year ago #

    Hello laguilar79,

    ok, you mean the plugin bersion 2.0.10 with WP 3.5 works correct?

    hm ... i will check the compatiblity of my other plugins in my wordpress and then i will update to 3.5.1.

    i will write in the next days ....

  9. la79
    Member
    Posted 1 year ago #

    Yes, the plugin 2.0.10 works fine with WP 3.5 and 3.5.1. When I upgraded to 2.0.11 it broke.

  10. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Guys: this is a really weird issue, and not one I've been able to recreate. That said: I just talked with the entire support crew about this, and all of us have seen some variation on it reported since the release of 2.0.11.

    I've got the devs looking into this now - it seems we may have introduced some problematic code in 2.0.11, which explains why it wasn't occurring for some of you in 2.0.10. It might make sense to downgrade in the interim, which I apologize for, but know that we're working to patch it so this shouldn't be an issue for long. Once I hear back regardless, I will pass an update your way.

    Thanks for your patience and support so far. If you need anything in the interim, don't hesitate to contact me (pro a/ tri.be) and we'll do our best to assist.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.