WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Warning: in_array() expects parameter (7 posts)

  1. greencode
    Member
    Posted 2 years ago #

    When I go into my Media library I get the following at the top of the page:

    Warning: in_array() expects parameter 2 to be array, null given in /home/mysite/public_html/wp-includes/query.php on line 2399

    It lists the same message about 9 times.

    Any ideas?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    You have a faulty plugin. Try installing the Hotfix plugin:
    http://wordpress.org/extend/plugins/hotfix/

  3. greencode
    Member
    Posted 2 years ago #

    Thanks for replying so quickly. I'm a little confused as to how this plugin works and what actually it does. I've installed it but where is it??

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    It fixes a set of specific issues in WP 3.0 - 3.1.x You don't have to do anything with it. Just activate it.

  5. greencode
    Member
    Posted 2 years ago #

    Great. Thanks for this and it appears to have fixed my original problem.

  6. vehicros
    Member
    Posted 2 years ago #

    Wow, I had this same problem, on one site, but not the other, So I just downloaded HotFix.
    No luck, didnt solve my problem, so I think Ill try updating wordpress, even though I do not care for the admin menu bar at the top of the page.

  7. greencode
    Member
    Posted 2 years ago #

    @vehicros - you can remove the admin bar at the top of the page by going into your user settings.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.