WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Warning: imap_open() [function.imap-open]: Couldn't open stream {pop.gmail.com:9 (9 posts)

  1. webcabbie
    Blocked
    Posted 1 year ago #

    Hello,

    I am running postie succesfully on one blog with no issues and attempted to get it set up and running on another blog but I am getting errors.
    Warning: imap_open() [function.imap-open]: Couldn't open stream {pop.gmail.com:995/service=pop3/ssl/notls/novalidate-cert}INBOX in /home/onlybigb/public_html/wp-content/plugins/postie/postieIMAP.php on line 86

    I don't understand what the issue is? Can you help please?

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    That is a generic failure message. Please doublecheck your email and password. Is this new blog on the same server? Some cheap hosting accounts don't allow connections to outside mail services like gmail.

  3. webcabbie
    Blocked
    Posted 1 year ago #

    I just got your response now. Thank you so much for trying to help. I asked the hosting company to check and I am waiting to hear back. I double checked that the login credentials were correct and gmail was enabled the same way that it is for the other account/site I have postie running on. tried again.. seems like slightly different error.

    Warning: imap_open() [function.imap-open]: Couldn't open stream {pop.gmail.com:995/service=pop3/ssl/notls/novalidate-cert}INBOX in /home/onlybigb/public_html/wp-content/plugins/postie/postieIMAP.php on line 86
    Mail Connection Time Out
    Common Reasons: Server Down, Network Issue, Port/Protocol MisMatch
    The Server said:

    Warning: imap_close(): supplied argument is not a valid imap resource in /home/onlybigb/public_html/wp-content/plugins/postie/postieIMAP.php on line 157
    There are 0 messages to process

  4. webcabbie
    Blocked
    Posted 1 year ago #

    Host insists port is open and listening... Im stumped.

    Warning: imap_open() [function.imap-open]: Couldn't open stream {pop.gmail.com:995/service=pop3/ssl/notls/novalidate-cert}INBOX in /home/onlybigb/public_html/wp-content/plugins/postie/postieIMAP.php on line 86
    Unable to connect. The server said:

  5. webcabbie
    Blocked
    Posted 1 year ago #

    Ok solved it! YAAAAAAAAAAAA all by myself....sing it people!

    So here is what was up.. Gmail marked the first login attempt yesterday as suspicious. I didnt know that because I had no plans to ever actually log into that gmail account again after I created it.

    So I found that and it still wouldnt let me pull the mail with postie.
    because of the suspicous activity... I reset that and still not working.. apparently I had to clear the captcha.

    Thank you and sorry for the bother! Is there a way to strip the senders email from the posts created?
    I'm having trouble logging in with my username and password

    If you're repeatedly prompted for your username and password, or if you're getting an 'invalid credentials' or 'web login required' error, make sure your password is correct. Keep in mind that password are case-sensitive.

    If you’re sure your password is correct, sign in to your account from the web version of Gmail instead at http://mail.google.com

    In most cases signing in from the web should resolve the issue, but you may also want to try these troubleshooting tips:

    Make sure your mail client isn't set to check for new mail too often. If your mail client checks for new messages more than once every 10 minutes, your client might repeatedly request your username and password.
    Try clearing the CAPTCHA (learn more). If you're a Google Apps user, and this doesn't work, you may not be a transitioned Google Apps account user yet. Try https://www.google.com/a/yourdomain.com/UnlockCaptcha instead. Be sure to replace 'yourdomain.com' with your actual domain name.
    Try changing your password according to our tips on creating a strong password.
    Mar 29, 2013

  6. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Glad you got it working. I forgot about that particular issue.

    >Is there a way to strip the senders email from the posts created?
    Not sure what you mean. Do you have an example of what is happening and what you want to happen?

  7. webcabbie
    Blocked
    Posted 1 year ago #

    Can you shoot me an email and I`ll show you an example of what I am doing and the problem I am having? If you canhelp great if its not something you want to do I understand. haverhilltaxi@gmail.com with postie in the title.

  8. Imofx
    Member
    Posted 12 months ago #

    Adding insult to injury here....;)

    I have the very same problem as described by webcabbie.

    Warning: imap_open() [function.imap-open]: Couldn't open stream {pop.gmail.com:995/service=pop3/ssl/tls/novalidate-cert}INBOX in /mnt/web9/a0/84/52151784/htdocs/wp-content/plugins/postie/postieIMAP.php on line 86

    No matter what settings I try, I keep getting this message.

    Here are my settings for activating Postie on a Gmail account:

    Mail Protocol: pop3-ssl
    Use Transport Layer Security (TLS): yes
    Choose Yes if your server requres TLS
    Port: 995
    Standard Ports:
    POP3 - 110
    IMAP - 143
    IMAP-SSL- 993
    POP3-SSL - 995

    Mail Server: pop.gmail.com
    Mail Userid: my gmail account mailaddress
    Mail Password: obivous ;)
    Postie Time Correction: 2 hours

    Any ideas ? (btw: I don't use a Captcha)

  9. Wayne Allen
    Member
    Plugin Author

    Posted 12 months ago #

    See: http://postieplugin.com/postie-gmail/

    You need to turn TLS off

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.