WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress user account type lite
Warning: Illegal string offset 'buat_default_type_selection' in (9 posts)

  1. Nehemc
    Member
    Posted 7 months ago #

    First i installed BuddyPress. After that i install this plugin.

    After installing "BuddyPress user account type lite" i had this error displayed on top of the page in admin panel:

    Warning: Illegal string offset 'buat_default_type_selection' in D:\Projects\inprogress\xampp\htdocs\ppps\wp-content\plugins\buddypress-user-account-type-lite\include\admin\buat-admin-pages.php on line 76

    How to fix this error.

    It will be very useful for me. Thank you in advance.

    http://wordpress.org/plugins/buddypress-user-account-type-lite/

  2. Shaswat Saxena
    Member
    Posted 4 months ago #

    I'm also getting this error.
    Looks like the Developer is ignoring lite version users.

  3. mizzinc
    Member
    Posted 4 months ago #

    On line 76 change:

    if(isset($_POST['buat_selected_field']) || $current_basic_setting['buat_default_type_selection'])

    to this

    if(isset($_POST['buat_selected_field']) || isset($current_basic_setting['buat_default_type_selection']) )

    Need to check if $current_basic_setting['buat_default_type_selection'] exists.

  4. manakio2k
    Member
    Posted 4 months ago #

    I'm getting the same error. I have a multisite install.

  5. manakio2k
    Member
    Posted 4 months ago #

    @mizzinc I tried your code but it didn't work.

    The author's site is down, I wounder if we will hear anything from them...

  6. mizzinc
    Member
    Posted 4 months ago #

    Yeah, I also discovered there were plenty more errors too, sorry manakio2k.

    Ended up deleting the plugin and using another method, albeit basic for my needs.

  7. dio1987
    Member
    Posted 3 months ago #

    It's obvious they try to sell the pro version. Any alternatives?

  8. twopheat
    Member
    Posted 2 months ago #

    I bought the $25 dollar pro version, and it too is failed, the site is down, and no replies from the designer. Numerous errors when it is turned on, though was awesome before.

  9. Chris F.
    Member
    Posted 2 months ago #

    I had this same issue. FYI, there is another plugin called "Capability Manager Enhanced" that will do the same thing plus more - See: http://wordpress.org/plugins/capability-manager-enhanced/

Reply

You must log in to post.

About this Plugin

About this Topic