WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Warning! Garbage collection is not scheduled! ...Can't fix! (6 posts)

  1. Brian
    Member
    Posted 1 year ago #

    Hi - I'm seeing that big yellow message at the top, "Warning! Garbage collection is not scheduled!"

    So I tried scrolling down the advanced page, Selected "Timer", hit the blue Update button, but it reverts back to "Clock" with a setting of 00:00 (screenshot), and the yellow Warning! remains.

    I also tried leaving the selection on clock, and setting a time, like 03:00, but same thing. Click "Update" and it reverts to 00:00. Warning remains.

    So I installed the Cron View plugin. I see these two lines, and I'm not sure if these are for super cache or for something else... wp_scheduled_delete and wp_scheduled_auto_draft_delete (screenshot)

    Any idea how to fix this???

    By the way - I'm running WP Multisite, with super cache 'Network Activated'.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. a_usman
    Member
    Posted 1 year ago #

    According to my experience every time you change any settings in the plugin, the Garbage collection turns to default. So you have to set it again. After you hit the save button, simply reload the page in the browser and you'll see the settings have been saved. Now until you make any change, the settings will remain saved.

  3. Brian
    Member
    Posted 1 year ago #

    I tried what you said - reloading the page after saving the Garbage collection settings... doesn't solve the issue.

    I created a quick screencast to demonstrate what I'm seeing: http://www.screenr.com/tAW7

    Again - clicking the blue "Update Settings" will not save the Garbage collection settings. They always revert to the default immediately.

    donncha - Is this a bug?

  4. Brian
    Member
    Posted 1 year ago #

    This is STILL not resolved.

    It's also happening on a 2nd website, so it's not isolated to the one website.

    Anyone have the same issue?

    Is there a fix?

  5. Stuntbox
    Member
    Posted 1 year ago #

    I'm having the exact same issue as Brian. This started happening after editing a few seemingly unrelated settings in the Advanced tab.

  6. questions4wp
    Member
    Posted 1 year ago #

    I too have this issue, though I have been able to solve it.

    To replicate the issue, first install the plugin, then enable caching. Go to the Advanced tab, and choose to use the "mod_rewrite" instead of PHP caching. At that point, you'll be asked to update your mod_rewrite rules. Once that's done, the garbage collection warning comes up. The default setting for garbage collections (which was 600 seconds in "timer") is instead set to 00:00 in "hourly". If you simply check off 600 seconds in "timer" again and click on the "Change expiration" button, the warning goes away.

    It appears that the issue is that the default (or for that matter, the user's custom garbage collection settings) get overwritten when mod_rewrite is chosen as the caching engine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.