WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Warning: Fatal error; Failed to open, No such file, etc, etc, (4 posts)

  1. warning
    Member
    Posted 7 years ago #

    I've uploaded wordpress to my server following the instructions. All the required files appear to be there, but then when I get to run the "admin/install.php", that's when fatal error, no such, failure occurs.

    The error code looks like this (digits replaced with "XX..." for privacy):

    Warning: main(/homepages/XX/XXXXXXXX/htdocs/wordpress/wp-includes/wp-db.php) [function.main]: failed to open stream: No such file or directory in /homepages/XX/XXXXXXXXXX/htdocs/wordpress/wp-settings.php on line 72

    Fatal error: main() [function.require]: Failed opening required '/homepages/XX/XXXXXXXXXX/htdocs/wordpress/wp-includes/wp-db.php' (include_path='.:/usr/local/lib/php') in /homepages/XX/XXXXXXXXXX/htdocs/wordpress/wp-settings.php on line 72

    I've been through the troubleshooting guide, but couldn't find anything relevant to this issue. It seems everything's addressed except for this. I can't figure out what's wrong, please help.

  2. whooami
    Member
    Posted 7 years ago #

    the error tells you exactly what the problem is:

    xxx/xxx/htdocs/wordpress/wp-includes/wp-db.php' isnt there.

    THAT or it cannot read the file, ie youve managed to chmod the file to unreable permissions.

    My bet is on the first solution though. :P It happens again and again, where someone thinks theyve uploaded everything and they havent, theyre using the right password but theyre not..

    Check that path again, for that file, Ill bet its not there. :)

  3. warning
    Member
    Posted 7 years ago #

    whooami

    Yes, the problem was that not everything had been uploaded. I'd missed the individial files under wp-includes, assuming they would just go along with the parentfolder upload, but they didn't. I have now uploaded them separately,

    thanks

  4. indiaberry
    Member
    Posted 7 years ago #

    I also ran into this problem in the last hour. It turned out that I forgot to upload the 'wp-includes' folder. You might want to try upload that folder again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags