WordPress.org

Ready to get started?Download WordPress

Forums

Warning: ... failed to open stream (17 posts)

  1. theopye
    Member
    Posted 9 years ago #

    ok, the upgrade from 1.2 to 1.5 went off without a hitch. then i logged out and went to logging again....
    now i recive this error message when trying to view my URL-

    Warning: main(/home/indiebox/public_html/wp-includes/wp-db.php): failed to open stream: Permission denied in /home/indiebox/public_html/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/indiebox/public_html/wp-includes/wp-db.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/indiebox/public_html/wp-settings.php on line 39

    i checked the checked 'wp-db.php', found out that's all redirect for the sql db. went onto checking line 39 of 'wp-settings.php'

    39:
    define('WPINC', 'wp-includes');
    require_once (ABSPATH . WPINC . '/wp-db.php');

    which i take as meaning: 'http://indiebox.com/wp-includes/wp-db.php'
    and that's the correct directory.

    i've also tried to CHMODing to see if that was the problem... no help there...

    i'm not an expert (by no means)- am i missing something?

    the files seem in order, but i have know idea what's going on. anyone got any suggestions?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    How exactly did you upgrade ?

  3. theopye
    Member
    Posted 9 years ago #

    i followed this to the 't', or so i think....
    http://www.tamba2.org.uk/wordpress/upgrade/upgrade_en.html

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What chmod combinations have you tried on the files / folders ?

  5. theopye
    Member
    Posted 9 years ago #

    i've tried everything, i ever went in and set open access to everything.... folders> then files... but that didn't work so i changed it back to 644

  6. theopye
    Member
    Posted 9 years ago #

    i think i'll try restoring the original 1.2 config then updating again... i must have missed something.

  7. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Before you do that.

    Try deleting the wp-includes directory and redownloading it. May not do anything, but it might save you a spot of effort.

    Or even deleting everything (except wp-config.php, etc) and redownloading.

  8. jayhuff
    Member
    Posted 9 years ago #

    I just updated myself and I have a ton of error messages when logged into the admin and I get this message after each entry on the page:
    Warning: main(/home/rambling/public_html/wp-comments.php): failed to open stream: No such file or directory in /home/rambling/public_html/index.php on line 42

    Warning: main(/home/rambling/public_html/wp-comments.php): failed to open stream: No such file or directory in /home/rambling/public_html/index.php on line 42

    Warning: main(): Failed opening '/home/rambling/public_html/wp-comments.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/rambling/public_html/index.php on line 42

    I am getting a little nervous now!

    Is there a way to save what is in the dbase and upload everything after a clean install?

  9. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    What does your BASE (as opposed to your theme's) index.php look like?

    It should be short: post it all here.

  10. jayhuff
    Member
    Posted 9 years ago #

    not sure what you mean... what the tables look like?

  11. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    No... maybe you have a different setup than what I assumed.

    Did you follow this guide? http://www.tamba2.org.uk/wordpress/upgrade/upgrade_en.html

    If so, your new index.php should only be a few lines long. The real work is done by the index.php in your theme's directory.

  12. jayhuff
    Member
    Posted 9 years ago #

    No I did not follow this... I just followed the readme file in the download. That sucks because I probably screwed up everything. I may just go back an restore my old files! Sheesh.
    I have some reading to do I guess. Thanks for that link.

  13. theopye
    Member
    Posted 9 years ago #

    RE: "Before you do that.

    Try deleting the wp-includes directory and redownloading it. May not do anything, but it might save you a spot of effort.

    Or even deleting everything (except wp-config.php, etc) and redownloading. "

    I've already tried...
    [edit] i tried upgrade.php after doing this and it seems to be functional- except for the sql linking (i think) the homepage is blank, and during install i got a bunch of sql errors... now, how can i fix that?

  14. Joshua Sigar
    Member
    Posted 9 years ago #

    I got nothing so, did you run the wp-admin/upgrade.php?

  15. theopye
    Member
    Posted 9 years ago #

    yes... see above-> i edited my last post as you replied... :)

  16. theopye
    Member
    Posted 9 years ago #

    Ok, i deleted everything wp except sql and config.php recopied everything over to web. i reinstalled now everything is in working order. i followed the tutorial: http://www.tamba2.org.uk/wordpress/upgrade/upgrade_en.html
    made it real easy, i guess something didn't upload correctly. thanks for the help you guys!
    -b

  17. jayhuff
    Member
    Posted 9 years ago #

    My issue was resolved as well. I needed to turn off the plugins and didn't do that. I also was trying to use my original index.php file and not transfer files into the "theme" folder. All in working order now!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.