WordPress.org

Ready to get started?Download WordPress

Forums

WP Calendar
Warning: Creating default object from empty value in (11 posts)

  1. alemay
    Member
    Posted 1 year ago #

    Getting the following error after upgrading to 1.5.3 see http://www.icologie.com/events/ for example

    http://wordpress.org/extend/plugins/wp-calendar/

  2. Hans-Josef Wolf
    Member
    Posted 1 year ago #

    Got that same thing: "Warning: Creating default object from empty value in /homepages/16/d24182738/htdocs/wp-content/plugins/wp-calendar/fsCalendarEvent.php on line 69"

    WP 3.5.1
    WP Calender 1.5.3

  3. alemay
    Member
    Posted 1 year ago #

    I also get this at the top of the calendar page

    Warning: Creating default object from empty value in /homepages/32/d67215390/htdocs/icologie/wordpress/wp-content/plugins/wp-calendar/fsCalendarAdmin.php on line 367

    WP 3.5.1
    WP Calendar 1.5.3

  4. alemay
    Member
    Posted 1 year ago #

    Hi Faebu,

    Would you have any advice on this. I'm going to have to go back to 1.4.

    Thanks Andy

  5. wmgtam
    Member
    Posted 1 year ago #

    This is happening for me, too. The error is because $evt is expected to be an object, and my environment has php set "strict"

    In fsCalendarEvent.php at line 69 is

    $evt->eventid = 0;

    I inserted a line above it to instantiate $evt as a class to fix it.

    $evt = new stdClass();
    $evt->eventid = 0;

    It seems to work for me.

  6. alemay
    Member
    Posted 1 year ago #

    Hi wmgtam,

    That got rid of the first error. But there still appears to be an error in fsCalendar.php.

    Error is

    Warning: date() expects parameter 2 to be long, string given in .../wordpress/wp-content/plugins/wp-calendar/fsCalendar.php on line 1291

    Any idea?

    Thank you for you help

    Andy

  7. murklan
    Member
    Posted 6 months ago #

    Thanks wmgtam that line

    $evt = new stdClass();

    seemed to fix my problem with fsCalendarAdmin.php too.

  8. skylar180
    Member
    Posted 6 months ago #

    Thanks wmgtam
    it worked for me too.

  9. dsg257
    Member
    Posted 4 months ago #

    I got the same problem after updating the PHP to 5.4 on the server
    1and 1 fixed it I was referencing the php wrong in the .htaccess file posted code in other thread
    http://wordpress.org/support/topic/php-warning-messages-and-not-able-to-create-a-category?replies=7

  10. efebert
    Member
    Posted 4 months ago #

    Hi wmgtam, hi dsg257
    at first, the definition of the new class $evt worked for me, too.
    But as I also use the provider 1und1, I tried dsg257's solution thereafter.
    Success.
    The upgrade from PHP 5.2 to PHP 5.4 had obviously been the reason for WPcalendars misbehaviour.

  11. dsg257
    Member
    Posted 3 months ago #

    I am still looking for the problem and the solution to the php 5.4 as I need the calendar and 1and1 will force the update sooner or later
    have been trying to find out what exactly causes the problem so I can ask for help on other forums

    so if you know the cause post it here

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.