WordPress.org

Ready to get started?Download WordPress

Forums

Page Restrict
Warning: Creating default object from empty value (4 posts)

  1. greendolphin
    Member
    Posted 1 year ago #

    Warning: Creating default object from empty value in \pagerestrict\pagerestrict.php on line 65.

    This appears on the login page. I am using the latest version 2.07.

    The plugin worked fine before i upgraded to the latest version of xampp.
    Thanks for your assistance.

    Green Dolphin

    http://wordpress.org/extend/plugins/pagerestrict/

  2. caoyue2913
    Member
    Posted 1 year ago #

    I have got the same problem. I'm working with wordpress 3.42

  3. caoyue2913
    Member
    Posted 1 year ago #

    Hi, greendolphin, it seems i have just solve this problem. Just open the \pagerestrict\pagerestrict.php file, replace the "->" in line 65 with "_". It do works for me!

  4. relish1227
    Member
    Posted 1 year ago #

    I noticed a similar warning with a different plugin (http://wordpress.org/support/topic/plugin-magic-fields-php-54-compatibility?replies=6#post-3706704) after upgrading to PHP 5.4. Guessing that this also somehow relates to PHP 5.4?

    I actually just commented out that line 65, as it just seems to be setting the comment_status to closed. (Thinking it wouldn't affect me because I don't have comments open anyways). That resolved the issue for now. However, would be better if this was in the next plugin upgrade. Whaddya think, plugin authors?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic