WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Warning: Cannot modify header information (15 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    When i want to login i only get this message. Don't understand it. :/

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1) in /var/www/web521/html/trashpage/wp-login.php on line 260
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1) in /var/www/web521/html/trashpage/wp-login.php on line 272
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1) in /var/www/web521/html/trashpage/wp-includes/pluggable.php on line 595
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1) in /var/www/web521/html/trashpage/wp-includes/pluggable.php on line 596
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1) in /var/www/web521/html/trashpage/wp-includes/pluggable.php on line 597
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1) in /var/www/web521/html/trashpage/wp-includes/pluggable.php on line 770
  2. Roy
    Member
    Posted 6 years ago #

    Start here.
    If necessary, read a little more here.

  3. Anonymous
    Unregistered
    Posted 6 years ago #

    I read the Answers Trouble Shooting about this problem, but i don't get it. I deleted <?php and ?> and reworte it, and there aren't any spaces... :/

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    Now i've eddited the wp-config.php 1000 times and deleted all spaces,

    1. Place the cursor between the ? and >
    2. Now press the DELETE key on your computer
    3. Keep that key pressed
    4. For at least 15 seconds
    5. Now type > and
    6. save without pressing any other key at all.
    7. If you press another key, you will bring the problem back.

    in this way, it doesn't work. I added nothing to config.php, i downloaded wp-config-sample again and did it again and again :/

  5. Roy
    Member
    Posted 6 years ago #

    Hm, it's the most likely problem. What if you take the wp-config sample from the WP download, insert the right information (again), save as wp-config and reupload?

    Otherwise, I can only suggest to read some other 'cannot modify header information' treads to see if it could be something else...

  6. Anonymous
    Unregistered
    Posted 6 years ago #

    i downloaded wp-config-sample again and did it again and again :/

    u see, i tried it.

    I used the Windows "Editor" und "Dreamweaver", both doesn't work.

  7. Samuel B
    moderator
    Posted 6 years ago #

    You must use a simple text editor like Notepad or clone.
    Also, have you disabled all of your plugins?

  8. whooami
    Member
    Posted 6 years ago #

    its not a plugin issue. the error you pasted is caused by characters or line breaks or spaces before the opening <?php in your wp-config.pgp

  9. Anonymous
    Unregistered
    Posted 6 years ago #

    I've downloaded Notepad and did it again and again, doesn't work!

    Hier is the full code:

    <?php
    //** MySQL-Einstellungen **//
    define('DB_NAME', 'XXX');    // Der Name der Datenbank
    define('DB_USER', 'XXX');     // Ihr MySQL-Benutzername
    define('DB_PASSWORD', 'XXX'); // Sowie das MySQL-Passwort
    define('DB_HOST', 'localhost');    // Diesen Parameter müssen Sie in den allermeisten Fällen nicht ändern
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    
    // Wenn Sie mehrere WordPress-Installationen in einer Datenbank haben,
    // muss jede Installation ein eigenes "Tabellenpräfix" bekommen
    $table_prefix  = 'wp_';   // Bitte nur Zahlen, Buchstaben und/oder Unterstriche
    
    // Setzen Sie für AUTH_KEY, SECURE_AUTH_KEY und LOGGED_IN_KEY ein Passwort oder
    // einen langen Satz ein. Sie werden ihn später nicht mehr benötigen, daher
    // machen Sie ihn ruhig lang und kompliziert. Unter http://api.wordpress.org/secret-key/1.0/
    // können Sie einen langen Passwortsatz automatisch generieren lassen.
    define('AUTH_KEY', 'Fuegen Sie hier einen beliebigen Satz ein.');
    define('SECURE_AUTH_KEY', 'Fuegen Sie hier einen beliebigen Satz ein.');
    define('LOGGED_IN_KEY', 'Fuegen Sie hier einen beliebigen Satz ein.');
    
    // Ändern Sie den folgenden Parameter, wenn Sie eine übersetzte Version von
    // WordPress nutzen. Für die gewünschte Sprache muss eine MO-Datei in
    // wp-content/languages liegen.
    // Installieren Sie beispielsweise de_DE.mo in wp-content/languages und
    // setzen Sie WPLANG auf 'de_DE', um WordPress auf deutsch zu haben.
    define ('WPLANG', 'de_DE');
    
    /* Ab hier sind keine weiteren Änderungen notwendig. Viel Spaß beim Bloggen! */
    
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
  10. whooami
    Member
    Posted 6 years ago #

    what you paste here doesnt show anything -- since you wont see it in a copy and paste. If you have shell access you can see the problem by performing a cat on the file.

    This has been covered time and time and time again..

    http://wordpress.org/search/wp-config.php%3A1+already+sent?forums=1

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web521/html/trashpage/wp-config.php:1)

  11. Anonymous
    Unregistered
    Posted 6 years ago #

    I read about 100 of these threads...

  12. Anonymous
    Unregistered
    Posted 6 years ago #

    Now it works.. i can't believe it. I downloaded the original wp-config-sample and eddited it again with all programms, and it worked with some shit, called "the coder maker" from italy....

    Thank you guys!

  13. mrmist
    Forum Janitor
    Posted 6 years ago #

    Good-o. :)

  14. Dns
    Member
    Posted 6 years ago #

    Please link me this shit :( i got same problem

  15. purabdk
    Member
    Posted 6 years ago #

    i solved this problem
    use this code
    <?
    //dont use header function in wordpress-wp_signup.php
    global $domain;
    global $path;
    //change urlnew variable as per requirment
    $urlnew = "http://".$domain.$path."/wp-admin/admin.php;

    echo "<script>";
    echo "location = '$urlnew';";
    echo "</script>";
    echo $urlnew;
    ?>
    Purab Kharat

Topic Closed

This topic has been closed to new replies.

About this Topic