WordPress.org

Ready to get started?Download WordPress

Forums

church_admin
[resolved] Warning - cannot modify header information (8 posts)

  1. bmrohde
    Member
    Posted 5 months ago #

    After updating Church Admin plugin this morning, I am getting numerous errors and can no longer log in to administer the site. Help please ASAP!

    https://wordpress.org/plugins/church-admin/

  2. bmrohde
    Member
    Posted 5 months ago #

    Don't worry - all fixed. Don't install the latest version - not compatible with 3.8.1. Ended up manually downgrading to an earlier version to fix the problem.

  3. andy_moyle
    Member
    Plugin Author

    Posted 5 months ago #

    One or two people have reported problems updating, but I've updated on 3 sites with no problems - all of which are 3.8.1.

    What errors did you get?

  4. reformedmedia
    Member
    Posted 5 months ago #

    So, the solution is to revert to an earlier version?
    I tried to make a back up of my contacts into a CSV file, but it's giving me this warning, which I think might be related to the above issue.

    'Warning: Cannot modify header information - headers already sent by (output started at /home2/hamlin2/public_html/wp-content/plugins/church-admin/index.php:1) in /home2/hamlin2/public_html/wp-content/plugins/church-admin/includes/pdf_creator.php on line 244'

    It's also giving me this message when I activate the plugin:

    'The plugin generated 6 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.'

    In addition, it's showing a 20px high white space between the left nav and the top nav.

    I've deactivated all my plugins except Church Admin but nothing is conflicting as it's acting the same way.

  5. reformedmedia
    Member
    Posted 5 months ago #

    In addition to the issues above, It's breaking my admin section. I see this message when I activate the plugin:

    'Warning: Cannot modify header information - headers already sent by (output started at /home2/hamlin2/public_html/wp-content/plugins/church-admin/index.php:1) in /home2/hamlin2/public_html/wp-includes/pluggable.php on line 896'</cod>

  6. thefutureisbright
    Member
    Posted 5 months ago #

    Hi, I'm getting this error when I install, anyone know what to do?

    Hosting on pagely and it's causing formatting issues in the admin.

    The plugin generated 6 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

  7. bmrohde
    Member
    Posted 5 months ago #

    andy - same errors as those reported above by other users. Couldn't log in to admin area ('Warning: Cannot modify header information - headers already sent by (output started at /home2/hamlin2/public_html/wp-content/plugins/church-admin/index.php:1)...' When trying to log in to Admin area, was getting the 'cookies' error in addition to the above. I ended going back to release 0.565 before the problem went away. I can now log back in successfully.

  8. andy_moyle
    Member
    Plugin Author

    Posted 5 months ago #

    I've found the issue!

    Recently edited files have been encoded with UTF8 with BOM rather than without BOM. It's the BOM that has caused the extra character(s) and thus the activation errors.

    Someone gave me access to their site which has had the activation errors (none of mine did ;-) and so have been testing. After about 6 updates, It now activates. so should work for you all now.

    Sorry for the disruption - v0.5857 should activate smoothly

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.