WordPress.org

Ready to get started?Download WordPress

Forums

Warning: Cannot modify header information (16 posts)

  1. Suaviterinmodo
    Member
    Posted 7 years ago #

    I'm trying to install wordpress at my website http://www.judithbarsi.com. I changed the details in my config file with notepad.

    Here is the error it gives me at http://www.judithbarsi.com/wordpress/wp-admin/install.php:

    Warning: Cannot modify header information - headers already sent by (output started at /home/celia/public_html/wordpress/wp-config.php:1) in /home/celia/public_html/wordpress/wp-admin/install.php on line 16

    Here is my config code:
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'celia_wordpress'); // The name of the database
    define('DB_USER', 'celia_celia'); // Your MySQL username
    define('DB_PASSWORD', '*************'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
    Line 16 is blank.

    When I went to find the language support folder, nothing was there. What do I have to do to get it to work?

  2. Dickie
    Member
    Posted 7 years ago #

    First point... it's best not to pubish your database login information online.. I suggest you change your login information as soon as possible.

    As far as the error is concerned the most likely problem is a blank line either at the start or the end of the file.
    Remove ANYTHING before and after the PHP open and close tags...
    <?php and ?>
    not even a space or a blank line...!

    That should sort out your problem

  3. Suaviterinmodo
    Member
    Posted 7 years ago #

    Okay. Noted.

  4. Suaviterinmodo
    Member
    Posted 7 years ago #

    Now it gives me this error:

    Warning: main(ABSPATH/wp-admin/admin-functions.php): failed to open stream: No such file or directory in /home/celia/public_html/wordpress/wp-admin/upgrade-functions.php on line 3

    Fatal error: main(): Failed opening required 'ABSPATH/wp-admin/admin-functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/celia/public_html/wordpress/wp-admin/upgrade-functions.php on line 3

  5. Suaviterinmodo
    Member
    Posted 7 years ago #

    P.S. I deleted my first database, changed my username and password.

  6. Dickie
    Member
    Posted 7 years ago #

    It's possible you have some corrupted files... Before you go any further I suggest you download the latest 2.0.5 set and upload all the files to the server again just to be sure.
    Then run your install/upgrade script.

  7. Suaviterinmodo
    Member
    Posted 7 years ago #

    I did download the latest wordpress. I'll try again.

  8. moshu
    Member
    Posted 7 years ago #

    Files get corrupted more often than you think: during the download, during the unzip, during the upload...

  9. Suaviterinmodo
    Member
    Posted 7 years ago #

    I finally figured it out. Thanks for your help, Dickie.

  10. Dickie
    Member
    Posted 7 years ago #

    No Problem.. out of interest what was the problem?

  11. slightly
    Member
    Posted 7 years ago #

    I am having the exact same issue:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/g/l/0/gl0mp/html/blog/wp-config.php:1) in /home/content/g/l/0/gl0mp/html/blog/wp-admin/install.php on line 15

    I created a brand new MySQL database (I even got through all the issues with GoDaddy+WordPress!), I got a fresh download of WordPress, my wp-config file has all of the proper information.

    Thanks to all the help texts and other threads out there, I was able to fix all of my previous issues, but I get to this one and none of the "help" is helping. Apparently the issue is with my wp-config file on line 1, right? And usually this error message means that there is extra white space before the <?php and/or after the ?> tags right? I've checked and checked them and they are fine. And so I did a complete re-install of the database and a fresh download and upload of wordpress and I am STILL getting this error. I don't see what the problem is. Can anyone help me out here?

  12. slightly
    Member
    Posted 7 years ago #

    Nobody? :(

  13. Clanham
    Member
    Posted 7 years ago #

    I have the same problem? Do you happen to be using Expression Web to edit your wp-config??????

  14. vkaryl
    Member
    Posted 7 years ago #

    Searching is good....

    Normally this sort of error is whitespace before the opening php tag in the noted file.

  15. ramirocjr
    Member
    Posted 7 years ago #

    Suaviterinmodo and All,

    I had a similar problem.
    That mistake of SQL can be easily solved removing the parameters
    ENGINE and COLLATION (that are not necessary, because we will never use other engine or collation - we can made it directly into the database).
    I suggest you to remove the command line using ENGINE and COLLATION - take a look in your WP-CONFIG.PHP, WP-SETTINGS.PHP and INSTALL.PHP.

  16. Tim Hyde
    Member
    Posted 7 years ago #

    I had this error. It really is as simple as white space.

    BUT not in the places above. It was introduced when installing a new theme.

    White space at the end of the functions.php file in the current theme!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic