WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms + Stripe
[resolved] Warning Array Key Exists Error ... (8 posts)

  1. benfranklin
    Member
    Posted 1 year ago #

    I did on successful transaction with a normal product.

    Then I installed recurring products and coupon with Stripe (Plus), the premium version.

    And then I started getting the error from the subject after I submit my payment info with two products, the subscription and a setup fee and apply a coupon:

    Warning Array Key Exists Error ... the first argument should be either a string or an integer in [...]/stripe.php on line 2384.

    I got this in both test mode and live mode and in both cases the credit card fields were highlighted in red when I got this message saying "The form cannot process your payment. Please contact your site owner."

    In test mode I see in my stripe dashboard that the payments seem to have gone through despite this error but they didn't go through with this error when I switched everything over to live mode.

    http://wordpress.org/extend/plugins/gravity-forms-stripe/

  2. Naomi C. Bush
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I don't provide support for +(More) Stripe here -- support information is in the email I sent you.

  3. chris7519
    Member
    Posted 1 year ago #

    Could you forward me the support information as well? I seem to be getting the exact same error. Thanks!!!

  4. Naomi C. Bush
    Member
    Plugin Author

    Posted 1 year ago #

    Support information is in the original email you received when you purchased +(More) Stripe

  5. Simplii Web
    Member
    Posted 1 year ago #

    I'm have the same issue with Ajax disabled/enabled.

    chrome console error-
    Uncaught SyntaxError: Unexpected number

  6. Simplii Web
    Member
    Posted 1 year ago #

    I tracked down the issue but not sure how to fix.

    this line of code

    if ( ( ! ( typeof address_line1 === 'undefined' ) ) &&

    is coming out like this

    if ( ( ! ( typeof address_line1 === 'undefined' ) ) &# 038;&

    not sure what is causeing the && to change to HTML version, most likely a filter but i disabled the theme filter, perhaps a new wordpress filter?

  7. i3inary
    Member
    Posted 1 year ago #

    Also having this error please send me support information.

  8. amirt
    Member
    Posted 1 year ago #

    Hi,
    I'm getting the same problem, with Organic Non-Profit Theme.
    Can you also please send me the support information?
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.