WordPress.org

Ready to get started?Download WordPress

Forums

Custom Community
Warning after installation custum community theme (8 posts)

  1. Ahri2012
    Member
    Posted 1 year ago #

    Hello,

    after the installation of my first buddy press, with the theme custum cummnunity i becam a warning .
    Warning: Creating default object from empty value in J:\xampp\htdocs\wp\wp-content\themes\custom-community\core\includes\bp\buddydev-search.php on line 49

    What´s the mistake of my installation on my home server.

    Many thank´s

    Frank

  2. miha.gorenjak1
    Member
    Posted 1 year ago #

    I have the same problem

  3. TJ Marsh(Arvixe)
    Member
    Posted 1 year ago #

    Seems like a plugin installed.. list your plugins?

  4. Full Circle
    Member
    Posted 1 year ago #

    Is buddypress installed?
    If not under theme settings / buddypress / global search you can change this to disabled to clear the error.

  5. Ahri2012
    Member
    Posted 1 year ago #

    Hello,

    @ tjmarsh
    these plugin´s are installed

    bbPress
    BuddyPress
    BuddyPress Werkzeugleiste
    CKEditor for WordPress
    Contact Form 7
    Fix Custom Fields in WP 3.4.2
    NextGEN Gallery
    Privates BuddyPress
    Really Simple CAPTCHA
    User Name Availability Checker for wordpress/buddypress
    User Role Editor
    WordPress Importer
    WP Events Calendar

    @ Full circle

    could i change it in the php file from the theme

    Many thank`s to all

  6. TJ Marsh(Arvixe)
    Member
    Posted 1 year ago #

    They all look like valid plugins. Try deactivating one by one and see if the site comes up.

    Looking for good quality webhosting for WordPress, look no farther then Arvixe.
    http://www.arvixe.com/wordpress_hosting

  7. Ahri2012
    Member
    Posted 1 year ago #

    So,

    i deactivated every plugin, but the problem is already there. then i installed wordpress new, then buddypress and then custom cummunity nothing else. And here it is the warning again :-(

    Warning: Creating default object from empty value in J:\xampp\htdocs\wp\wp-content\themes\custom-community\core\includes\bp\buddydev-search.php on line 49

    @ miha.gorenjak1
    did you find the mistake?

    Thank´s for your help

  8. Ahri2012
    Member
    Posted 1 year ago #

    Hello,

    so, i created a page/site with the title search and no content. Wenn i click on the button <repair> these error desappeard ...Die folgenden aktiven BuddyPress-Komponenten haben keine verbundenen WordPress-Seiten: Suche Seite<repair>
    but the error
    Warning: Creating default object from empty value in J:\xampp\htdocs\buddypress\wp-content\themes\custom-community\core\includes\bp\buddydev-search.php on line 49
    is already active....
    so i copy the php-text from line 49 here:

    function setup_globals(){
    global $bp;
    if(!defined('BP_SEARCH_SLUG'))
    define('BP_SEARCH_SLUG','search');//though we know it is set, just a safety bit

    $bp->search->slug=BP_SEARCH_SLUG; <<<< this is line 49
    $bp->search->has_directory=true;
    $bp->search->id='search';
    $bp->search->name=__('Search Page', 'cc');
    $bp->search->root_slug=isset($bp->pages->search->slug)?$bp->pages->search->slug:$bp->search->slug;
    }

    Must i create a articel or a kategorie .Or could someone explain me what these php line means.
    Custom Cumminity is so a great theme but i didn´t find where i made the mistake . :-(

    I hope it will help a lite bit, sorry for my bad english. My school time is a long time ago :-)

    Many thanks
    Frank

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic