WordPress.org

Ready to get started?Download WordPress

Forums

Want to remove sidebars on only one page (9 posts)

  1. davey579
    Member
    Posted 7 years ago #

    Is it possible to remove the sidebars on only one page? Because i want to remove the sidebars on my forum page.
    http://www.dakzoekje.nl

  2. BPartch
    Member
    Posted 7 years ago #

    Hello

    Open sidebar.php and add in there

    <?php /* If this is the forum page */ if ( is_page('ID')) { ?>Leave this empty<?php } ?>

    Just replace 'ID' with the ID number for that page. You can also use the page slug name.

  3. davey579
    Member
    Posted 7 years ago #

    doesn't work. i get the text Leave this empty (only on my forumpage) on top in my right sidebar. If i delete 'Leave this empty' i still get my sidebar.

  4. skulled
    Member
    Posted 7 years ago #

    Use this code:

    Add the following as the very beginning of your sidebar.php:

    <?php /* If not forum page */ if ( !is_page('25')) { ?>

    Add the following line to the very end of your sidebar.php:

    <?php } ?>

    That should do it. Let us know how it goes. :)

  5. davey579
    Member
    Posted 7 years ago #

    thanks! it works! Now i only want to know how i can make the forum (rs-discuss) more wider.

  6. skulled
    Member
    Posted 7 years ago #

    This is apparently the CSS for the forum plugin:

    <link rel="stylesheet" href="http://www.dakzoekje.nl/wp-content/plugins/rs-discuss/template.css" type="text/css" media="screen" />

    So check in that file, and see if it is setting widths, and accordingly adjust the widths.

  7. moshu
    Member
    Posted 7 years ago #

    Why is everybody misleading the poor OP?
    Removing the sidebar(s) will NOT make your content area wider - unless you have a spec Page template for which you define a different content div class or something.

    And for davey, what is coolcode.cn... "something" that your pages are waiting for it for minutes to appear???

  8. davey579
    Member
    Posted 7 years ago #

    in the template.css there's no setting to make it wider. And the coolcode.cn was the coolplayer plugin, but i turned it off.

  9. davey579
    Member
    Posted 7 years ago #

    And i've added a page template, thanks for the idea. It works now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.