WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wampserver home page instead of my website (23 posts)

  1. mrojas
    Member
    Posted 1 year ago #

    I've installed Wamp, a local server on my W7 laptop, and have installed WordPress 3.3.2. I've created a database and am able to get to the WordPress dashboard and have created a one page website. However, when I click on the Pages, and click on the only page listed, and then click on the view link, what I see displayed is the Wampserver Home Page instead of my one page website.
    Did I miss a step in my installation?

    Thanks in advance for your help.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Where did you install WordPress in your document root?

  3. mrojas
    Member
    Posted 1 year ago #

    Sorry but I'm new at this and I have no clue. How can I tell?

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Try looking in your document root folder for the WordPress files & folders.

  5. mrojas
    Member
    Posted 1 year ago #

    I'm sorry but I still can't seem to figure this out. Here's the tree structure of my Wamp installation:
    alias
    apps
    bin
    lang
    logs
    scripts
    tmp
    tools
    www

    Inside the www folder is where all the WP files are located.

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    www is your server's document root. Are all of the WP files in a wordpress sub-folder?

  7. mrojas
    Member
    Posted 1 year ago #

    They were not; however, when I created a wordpress sub-folder, and copied all files to it, I could no longer access WordPress via the Wamp menu (localhost) as I could when all the files were in the www folder.
    :-(

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Move everything back to its original location.

  9. mrojas
    Member
    Posted 1 year ago #

    I have all files back to their original location, but I'm still faced with the original problem; when I click visit website on the Dashboard page, the Wampserver configuration home page is displayed instead of my one page website.

  10. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Is there an index.html file in the www folder? If so, try renaming it to index-old.html.

  11. mrojas
    Member
    Posted 1 year ago #

    I've done that already, and when I did and click on visit website, I get standard error message 401
    Not Found

    The requested URL /index.php/ was not found on this server.

    8-(

  12. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    What files are in the wwww folder?

  13. mrojas
    Member
    Posted 1 year ago #

    The following files are in the www folder:
    .htaccess
    index.php
    license.txt
    readme.html
    testmysql.php
    wp-activate.php
    wp-app.php
    wp-blog-header.php
    wp-comments-post.php
    wp-config.php
    wp-confit-sample.php
    wp-cron..php
    wp-links-opml.php
    wp-load.php
    wp-login.php
    wp-mail.php
    wp-pass.php
    wp-register.php
    wp-settings.php
    wp-signup.php
    wp-trackback.php
    xmlrpc.php

    In addition, the following sub-folders:
    wp-admin
    wp-content
    wp-includes

  14. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    And what happens if you navigate to http://localhost/?

  15. mrojas
    Member
    Posted 1 year ago #

    The very same wampserver home page is displayed.

    So frustrating!

  16. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    What's in your root index.php file? If it is longer than 10 lines, please use the pastebin.

  17. mrojas
    Member
    Posted 1 year ago #

    Not only it's longer than ten lines, it's also in French! I've uploaded to PasteBin (Index File).

  18. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Pastebin url?

  19. mrojas
    Member
    Posted 1 year ago #

  20. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Rename that file to index.php.old and replace it with the index.php from the root folder of a fresh download of WordPress.

  21. mrojas
    Member
    Posted 1 year ago #

    Wow, it worked!

    Thanks a bunch!

  22. chiron34
    Member
    Posted 1 year ago #

    I have a problem similar to that resolved two days ago: wampserver home page instead of my website.

    I am a newbie to WordPress and wamp. I've set up local host on wamp server but have run into a technical problem. When I open Firefox>New Tab and enter 'localhost', or 'localhost/wp-admin', or any localhost-based word combination, I get automatically redirected to an AltaVista search result: http://us.yhs4.search.yahoo.com/yhs/search?fr=altavista&itag=ody&q=http://localhost/wp-admin/themes.php.

    Is there a reason for this? Do you think I did something wrong in my installation?

    It seems to me that a quick fix for this would be to change the name of 'localhost' in my wp-config.php file; e.g. - here's a cut and paste extract from my wp-config.php:

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'WordPress');
    
    /** MySQL database username */
    define('DB_USER', 'root');
    
    /** MySQL database password */
    define('DB_PASSWORD', '');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    Is it possible for me to just open wp-config.php and physically change 'localhost' to something like: chironhost (based on my project name that uses the word chiron in the title.

    I am reluctant to do this by myself when I don't know if there will be any adverse repercussions from making such a change directly in wp-config.php.

    Any suggestions, advice?

    Many thanks in advance for looking at this for me.

    sincerely

    chiron34

  23. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic