WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Wamp Server Not Working (16 posts)

  1. Chris Luckett
    Member
    Posted 3 years ago #

    Trying to set up WordPress on my computer to create a new website locally prior to purchasing hosting. Downloaded Wamp server. When I click on the tray icon Put Online, it doesn't go online.
    When I click on Start All Services, nothing happens.
    When I click on Local Host I just get an IIS7 window which goes to their website when you click on it.
    When I click on phpmyadmin, I get Server Error in Application "DEFAULT WEB SITE" HTTP Error 404.0 - Not Found
    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable. Cannot figure out what I am doing wrong. Would appreciate any help.

  2. datasoftict
    Member
    Posted 3 years ago #

    I am not sure about your WAMP, I have a WAMP server here configured to run all Apache Linux and Mysql individually. Is yours a one click installation that runs the three services in one?

    If so first thing to check is that apache is running, then MySQL then PHP.

    Where did you get the files? a brand or site location might help find waht is is, and therefore how it runs.

    Which windows are you on W7 I assume?

  3. Chris Luckett
    Member
    Posted 3 years ago #

    I just clicked on the Apache link to Install Service & a window popped up saying that: Your port is actually used by Server: Microsoft- IIS/7.5.
    I'm assuming that means I already have a server installed on my computer, but now need to know how to utilize it. Sorry but I'm very new to this & am finding it very confusing!
    Should I uninstall WAMP & use what I already have? If so, what now?
    Many thanks!

  4. Chris Luckett
    Member
    Posted 3 years ago #

    And yes, I have Windows 7.

  5. okimangelo
    Member
    Posted 3 years ago #

    If you installed WAMP on a computer with IIS installed, there is a big possibility that both local web servers are using the same port, which is port 80. You can verify this by connecting to http://localhost:80/
    When you are getting the IIS7 then this would mean that IIS7 is using port: 80.

    You can configure your wamp Apache server by navigating to 'C:\wamp\bin\apache\Apache2.2.17\conf' if you installed wamp on drive C. Open the httpd.conf file using notepad (Warning: You should change your "User Account Control settings" at Control Panel\All Control Panel Items\User Accounts to "Never Notify" before you could edit your httpd.conf file)

    On your 'httpd.conf' file look for these lines:

    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to
    # prevent Apache from glomming onto all bound IP addresses.
    #
    #Listen 12.34.56.78:80
    Listen 80

    Change the last line to Listen 443
    (From Listen 80 to Listen 443)

    This is changing the port that your wamp apache server would use to port 443. Save the httpd.conf file and restart your wamp server.

    After restarting verify the wamp server installation by launching 'http://localhost:443/
    If you are seeing the Wamp Server Home, then you are good to go.

  6. govpatel
    Member
    Posted 3 years ago #

    I found out that if you using skype then you need to change connection settings on skype
    Click on Tools>>>> Options>>>Advanced>>>Connections and un tick if is ticked to use port 80 and 443

  7. Chris Luckett
    Member
    Posted 3 years ago #

    Thanks to okimangelo I have the Wamp server working. However, it still seems to be connected to the 80 port somehow. When I manually type in the localhost443 it opens the Wamp homepage. But when I click on the Localhost icon in the Wampserver 2.1 pop up menu, it still goes to the 80 page. Also, when I click on the phgMyAdmin icon, I get an HTTP Error 404.0 - Not Found, indicating:
    Requested URL http://localhost:80/phpmyadmin/
    Physical Path C:\inetpub\wwwroot\phpmyadmin\
    Logon Method Anonymous
    Logon User Anonymous
    I'm assuming that something needs to be changed in the Wamp data, but what? Don't want to attempt installing WordPress until I get all this fixed!

  8. Chris Luckett
    Member
    Posted 3 years ago #

    Also, when I go to the http://localhost:443/phpmyadmin page, I get the following:
    Welcome to phpMyAdmin
    Error
    MySQL said:
    #1045 - Access denied for user 'root'@'localhost' (using password: NO)
    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.
    How do I do this?

  9. maoski
    Member
    Posted 3 years ago #

    I usually just stop IIS so the port80 is free

    http://technet.microsoft.com/en-us/library/cc770472%28WS.10%29.aspx

  10. Chris Luckett
    Member
    Posted 3 years ago #

    How do you stop IIS?

  11. okimangelo
    Member
    Posted 3 years ago #

    My bad, it appears that my first suggestion is not good because you need to change a lot of configuration files if we change the default port of WAMP which is port 80. I encountered this problem also when I tried installing IIS7.

    Maybe the best solution is to turn off or even uninstall IIS7 if you will not be using it. But if you would prefer using WAMP with IIS7, I suggest we change the default port that IIS7 is using.

    We can do this by navigating to Computer Management>Services and Applications>Internet Information Services>Sites>Default Web Site:
    On the 'Actions' Pane click 'Bindings', the Site Bindings Form will pop-up, now you can change the port that IIS will be using.

    Hope this helps.

    Snapshot

  12. Chris Luckett
    Member
    Posted 3 years ago #

    Thanks okimangelo. I actually stumbled across how to turn off IIS7, which I did. Wamp is now working & somehow I actually finally got WP installed.

  13. okimangelo
    Member
    Posted 3 years ago #

    You are welcome sir.

  14. Phil Gee
    Member
    Posted 3 years ago #

    I had the same problem and the solution was to do as Govpatel suggested

    I found out that if you using skype then you need to change connection settings on skype
    Click on Tools>>>> Options>>>Advanced>>>Connections and un tick if is ticked to use port 80 and 443

    Thanks

  15. Chris Luckett
    Member
    Posted 3 years ago #

    I'm not quite sure why Skype was ever brought up in this discussion. I don't have or use Skype.

  16. govpatel
    Member
    Posted 3 years ago #

    I did not know at time I posted that you do not have skype I just posted in General that skype does cause problem using Wamp as they both use the same port.

Topic Closed

This topic has been closed to new replies.

About this Topic