WordPress.org

Ready to get started?Download WordPress

Forums

OptionTree
[resolved] Wait! You need to install and activate the OptionTree plugin! (7 posts)

  1. davidrosenstein
    Member
    Posted 2 years ago #

    I'm getting this message: 'Wait! You need to install and activate the OptionTree plugin!' although it is installed and activated.

    The problem is that it reverted to the Theme Graphic on the website: http://www.rosestoneconstruction.com instead of the company logo!

    I cannot seem to upload the logo from Theme Options although it says that the logo has successfully uploaded when I removed it and uploaded it again a few time!

    Please advise!

    Thank you.

    http://wordpress.org/extend/plugins/option-tree/

  2. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    That is because the author of that theme has used something in the old version to test if the plugin is installed but whatever they used no longer exists.

  3. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    As to your theme reverting, Cudazi themes are not compatible with the new version of OptionTree. I've emailed the author to see if we can find a workaround but not heard back yet.

  4. michaelstegh
    Member
    Posted 2 years ago #

    Hi from Germany. :)

    i had the same problem. after updating optiontree i was still receiving the message mentioned in the opener post. I am using mono-theme vom cudazi.

    for me the following workaround fixed it. (but i am not sure, if this is really smart, because i am not a coder.)

    i navigated to themes-folder > mono > libraries > theme-options.php

    in theme-options.php i made the following changes:

    in line 10
    if ( ! is_plugin_active( 'option-tree/index.php' )

    i changed "index.php" to "ot-loader.php"
    if ( ! is_plugin_active( 'option-tree/ot-loader.php' )

    Uploaded theme-options.php back into the folder, ... after that the message did not show up anymore.

    While Derek has made some grand changes in his Plugin, the theme-author obviously couldn't notice, that Derek changed "index.php" to "ot-loader.php".

    As i mentioned, i am not a coder, but this fixed my error-message-problem.

    Hope this was a bit helpful? (Sorry for my bad english.) :-/

  5. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    Cudazi themes should now be compatible but the nag will not go away until the author updates their theme.

  6. davidrosenstein
    Member
    Posted 2 years ago #

    Thank you very much for the follow up to you Derek and Michael. And Michael your English is perfect.

  7. Ronner
    Member
    Posted 1 year ago #

    That solved it! Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic