WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] W3TC not working properly on self hosted CDN (2 posts)

  1. eosguy
    Member
    Posted 1 year ago #

    I've got a problem with the plugin on my own self hosted CDN.

    Basically:
    1. When I check the "upload attachments..." everything works except for the images. The images are on the CDN server but somehow the URL gets rewritten to just the CDN URL without any directory or filename. Example is IMG urls are written http://cdn.example.com instead http://cdn.example.com/123.jpg or http://cdn.example.com/2012/10/123.jpg

    2. If I were to set manual minify for CSS and JS and upload to CDN, the files won't be fetched even though it's on the server. If I were to copy the URL and open it manually it will give me a not found page. I checked using FTP and the file is there.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. eosguy
    Member
    Posted 1 year ago #

    Issue number is almost resolved due to media settings.

    Currently all my media files are already on the CDN - cdn.example.com/2012/10 etc (following WP yearly and monthly sorting).

    If I were to leave the media field blank, it'll try to access files from cdn.example.com/wp-content/upload/2012/10 etc. How do I make it ignore the wp-content/upload folders? I've used ./ in the field and the image URLs become cdn.example.com//2012/10 etc

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic