WordPress.org

Ready to get started?Download WordPress

Forums

Simple Events Calendar
w3c validation problem? (4 posts)

  1. bonnit
    Member
    Posted 1 year ago #

    the line which gives the style sheet for the simple events calendar is constantly being flagged in w3c validator, its my only error for my homepage and i cannot understand how to fix this, can someone please advise?

    the line being flagged:
    <link rel='stylesheet' id='sec-styling-css' href='http://vintagebonbon.co.uk/wp-content/plugins/simple-events-calendar/simple-events-calendar.css?ver=1.3.4' type='text/css' media='all' />

    W3C validator error message

    Error Line 489, Column 199: Element link is missing required attribute property.
    
        …s-calendar/simple-events-calendar.css?ver=1.3.4' type='text/css' media='all' />
    
    Attributes for element link:
            Global attributes
            href
            crossorigin
            rel
            media
            hreflang
            type
            sizes
    Also, the title attribute has special semantics on this element.

    my site link:
    http://vintagebonbon.co.uk/

    http://wordpress.org/plugins/simple-events-calendar/

  2. Jerry G. Rietveld
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Bonnit,

    If you can tell me what is wrong with the link element for the stylesheet I will happily make the changes to the plugin.

    I think however [making a bold assumption here] that you might have found a bug in the W3C validator. Maybe something is confusing it, because if you look at the link element it has the following attributes:
    - rel
    - id
    - href
    - type
    - media

    Compare that to any of the other stylesheets your calling in your site's HEAD. You'll find that they're all identical. So there doesn't seem to be anything wrong with that link.

    But again, please correct me if I'm wrong and I'll make the required changes.

    Thanks,
    Jerry

  3. mica123
    Member
    Posted 7 months ago #

    I came across this post by chance - I have a similar problem with another plugin, so I hope you won't mind if I ask for your advice here:

    the error message from Validator means that the reference to the plugin's stylesheet should be put within the HEAD tags. I checked everything in my plugin, but everything seems to be correct (wp_enqueue_style code seems to be correct) - so I am at a loss.
    I hope you'll be able to shed light on this.

    Many thanks.

  4. esmi
    Forum Moderator
    Posted 7 months ago #

    @mica123: If you require assistance then, as per the Forum Welcome, please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.