WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] W3C Minify won't work (10 posts)

  1. kiwi_de
    Member
    Posted 2 years ago #

    Minify doesn't work.

    Failure: recently an error occurred while creating the css / js minify cache: some files were unavailable, please check the settings to ensure the site is working as intended.

  2. CSD_Images
    Member
    Posted 2 years ago #

    I had this problem, and had to clear the cache then verify all the individual file URLs. You can verify the URLs when you go into manual model and add the individual files.

    If it 404s then check the file exists/linked properly and/or redirects to the proper place.

    Its' been a 'interesting' time learning this plug-in!

  3. mauryparra
    Member
    Posted 2 years ago #

    well i've got the same problem and I don't understand very well what steps follow to solve the problem... if CSD_Images or somebody can explain better it would be appreciated.

  4. CSD_Images
    Member
    Posted 2 years ago #

    I'm no expert at this but a bit of tinkering yesterday gave me the solution:

    Performance: General

    Under minify panel enable and set to manual, leave everything else as is.

    Performance: Minify

    You will see the option to clear cache next to this is the help wizard.

    Click on this and choose the scripts you want minified. Then check the URLs as it's only checking for links, not for files actual existence. This caught me out as one of my files as moved by accident on the server.

    Once you have chosen your files and back to the Performance interface you will see your list of files, next to that you will see delete/verify. It's here you will check for the files existence.

    Alternatively you could add each script individually and test exhaustively.

  5. kfawcett
    Member
    Posted 2 years ago #

    Please see my post in this link: http://wordpress.org/support/topic/minify-broken-in-latest-update?replies=8

    Basically it appears that after upgrading the minify arrays are getting messed up and need to be manually deleted before re-adding the files and enabling minify.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the trouble. Are you still having issues with the latest release?

  7. mauryparra
    Member
    Posted 2 years ago #

    Actually since the last release I start with this problem (0.9.2.3)
    Here is how it looks like Image

  8. tgeorge
    Member
    Posted 2 years ago #

    mauryparra's new problem is the same as the one described here :

    http://wordpress.org/support/topic/minify-broken

    I have the same problem, and it appeared with WordPress 3.2.

  9. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Ah, please disable that option for now it's not very reliable. If you want to submit bug submission forms about it for testing, that's also cool.

  10. scottdaris
    Member
    Posted 2 years ago #

    I don't know if this applies, but see my post about automatic minifying errors:
    http://wordpress.org/support/topic/plugin-w3-total-cache-important-parsing-found-with-automatic-minify
    (btw, I meant to say *Important* parsing error found with automatic minify)
    In the minifying process, incorrect .js code was generated. You'll see what I mean in my post. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic