WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache uses wrong file path (13 posts)

  1. cyonite
    Member
    Posted 4 years ago #

    I've got a bunch of problems with W3 Total Cache not caching any files in pgcache or being able to combining files.
    I think all problems is because it uses wrong file path.
    [Wed, 24 Mar 2010 10:43:21 +0000] [/cms/wp-content/w3tc-mydomain.com/min/default.include.css] The path "/var/www/mydomain.com/web/var/www/clients/client2/web2/web/cms/wp-content/themes/delegate/style.css" coulile)
    /var/www/mydomain.com/web/ is the same as
    /var/www/clients/client2/web2/web/
    Its symlink or whatever its called.
    How do I get W3 Total Cache to use the correct path and not combine them?

  2. Satya Prakash
    Member
    Posted 4 years ago #

    If you are looking for minify then I will also say that it does not work. So better do not use it. and also in one plugin where minify was working there IE was taking too much time to load the page for some reason. so check that also even if got success in minification.

    and also you may need to upload files your self. It only uses static files (style sheets, imgs ,..) from wp-content folder. Do not forget to change the Upload path in WP setting. I forgot that.

  3. Frederick Townes
    Member
    Posted 4 years ago #

    Can you submit a bug submission from the support tab of the plugin?

  4. cyonite
    Member
    Posted 4 years ago #

    I've submitted Bug thing with necessary information etc.

  5. Frederick Townes
    Member
    Posted 4 years ago #

    This should be fixed in the development version: http://wordpress.org/extend/plugins/w3-total-cache/download/

  6. mistercyril
    Member
    Posted 4 years ago #

    Hello,

    I'm using the latest version but i'm having the exact same problem as Andreas.

    The URI works when I test it in the settings page, but the output repeats the server path twice before the actual path I entered in the settings.

    Any idea how to work around this?

    Thank you for building this plugin. It looks promising.

    C.

  7. Frederick Townes
    Member
    Posted 4 years ago #

    Did you try yesterday's development version? If so, please submit a bug submission form.

  8. mistercyril
    Member
    Posted 4 years ago #

    Hello,
    I just installed today's development version before posting this to see if it would solve my problem, but it turns out that it doesn't... So here is the issue :

    I am running WP MU 2.9.2 & BuddyPress
    My host is Web Faction (which is very competitive and offers great support by the way) and it has Gzip and NGinx enabled.

    Question 1
    The problem I am having is that when I try to regroup .js files in the footer (for example) the url for the combined scripts is placed just before the </body> tag as it should be and looks like this :

    <script type="text/javascript" src="DOMAIN/wp-content/w3tc-domain.com/min/89d546/default.include-footer.188102117.js"></script>

    But this link renders a "HTTP/1.0 400 Bad Request"

    So I looked at the files generated on the server, and I have : wp-content/w3tc-domain.com/min/89d546/default.include-footer.js.id

    Shouldn't it look like this : default.include-footer.188102117.js

    Question 2
    I wanted to see if I was looking in the right direction so I checked out the log files and I noticed something else :

    [Tue, 20 Jul 2010 18:22:11 +0000] [/wp-content/w3tc-domain.com/min/89d546/default.include-footer.188102117.js] The path "/home/webapps/_/home/webapps/wordpress_mu_292_php/wp-content/plugins/magicmagnify/core/magicmagnify.js" could not be found (or was not a file)
    [Tue, 20 Jul 2010 18:22:11 +0000] [/wp-content/w3tc-domain.com/min/89d546/default.include-footer.188102117.js] No sources to serve

    Apparently, the first part of the server directory (/home/webapps/) is repeated twice and separated by an underscore.
    Why would that be added? I'm guessing this is a problem... isn't it?

    I hope you can help me out with this, i'm dying to use this plugin ;-)

    Best,
    C.

  9. Frederick Townes
    Member
    Posted 4 years ago #

    Nginx is not supported right now.

  10. mistercyril
    Member
    Posted 4 years ago #

    Is that what's causing this problem?

  11. Frederick Townes
    Member
    Posted 4 years ago #

    Must be since I have no idea how you have anything set up as I have not natively done anything for nginx yet.

  12. mistercyril
    Member
    Posted 4 years ago #

    My host just got back to me with this information :

    Nginx cannot be deactivated, however, your site is actually running on Apache and Nginx is just forwarding the requests to the Apache server so it is technically not running on Nginx.

    The problem is most likely in your .htaccess as that is the file that is used to write your URLs.

    There shouldn't be any special configuration you need to use to be able to use that plugin correctly. Check the .htaccess file and see if things there are not right.

    Any ideas?

    Thanks,
    C.

  13. Frederick Townes
    Member
    Posted 4 years ago #

    Not without seeing your settings. Bug submission report is needed (from the support tab of the plugin).

Topic Closed

This topic has been closed to new replies.

About this Topic