WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache throwing weird errors (9 posts)

  1. Ahmed
    Member
    Posted 2 years ago #

    So I try to install W3TC and I get these errors:

    "It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration."

    and

    "
    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration."

    Naturally, I double triple quadruple check the sever, no issues. I AM using .htacces indeed. So I check the compatibility check and it's full of "false postivies":
    mod_deflate: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_env: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_expires: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_headers: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_mime: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_rewrite: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_setenvif: Not detected (required for Page Cache (enhanced mode) and Browser Cache)

    The server DOES have these modules. So I am not sure what is going on here.

    Ideas?

  2. Frederick Townes
    Member
    Posted 2 years ago #

    Your server may be using fast cgi or similar, so the plugin can't detect the modules. Which web server are you using?

  3. Ahmed
    Member
    Posted 2 years ago #

    Hello Frederick,

    No FCGI, just Apache 2.22 + PHP 5.3.10 and suEXEC with suhosin and mod_security. The funny thing that I have dedicated servers using that setup, but the issue only appeared on the VPS, which is very interesting really.

    What do you think?

  4. Michael Cannon
    Member
    Posted 2 years ago #

    I'm in a similar boat. Ditto for the errors, running VPS. Two sites have these issues, different VPSs.

  5. Ahmed
    Member
    Posted 2 years ago #

    @Michael Cannon

    KVM based VPS by any chance?

  6. Michael Cannon
    Member
    Posted 2 years ago #

    @Ahmed,

    No. I've decided to turn off suphp and suexec and try recompiling the latest PHP/Apache for my ServInt VPS with cpanel.

    I'll see if things change shortly. I'm still trying to debug if it's permissions conflict because of the cgi or dso PHP instances.

    Ciao!

  7. Frederick Townes
    Member
    Posted 2 years ago #

    @Michael Cannon any update?

  8. Michael Cannon
    Member
    Posted 2 years ago #

    @Frederick, the recompile helped with the esoteric minification not working errors, but the feeds were fixed once I turned off caching for them. Sorry, no real information on how to reproduce the problem or the fix.

  9. Frederick Townes
    Member
    Posted 1 year ago #

    Do folks here want to submit a bug submission form from the support tab of the plugin for better help?

Topic Closed

This topic has been closed to new replies.

About this Topic